aboutsummaryrefslogtreecommitdiffstats
path: root/community/shfmt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shfmt/APKBUILD')
-rw-r--r--community/shfmt/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/shfmt/APKBUILD b/community/shfmt/APKBUILD
index 72ccab38d6f..62b998efcdf 100644
--- a/community/shfmt/APKBUILD
+++ b/community/shfmt/APKBUILD
@@ -2,12 +2,13 @@
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=shfmt
pkgver=3.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
url="https://mvdan.cc/sh"
-arch="all !mips !mips64"
+arch="all !mips !mips64" # limited by go
license="BSD-3-Clause"
-makedepends="go"
+makedepends="go scdoc"
+subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
builddir="$srcdir/sh-$pkgver"
@@ -16,6 +17,7 @@ build() {
-ldflags "-w -X main.version=$pkgver-$pkgrel" \
-v \
./cmd/shfmt
+ scdoc < cmd/shfmt/shfmt.1.scd | gzip > shfmt.1.gz
}
check() {
@@ -24,6 +26,7 @@ check() {
package() {
install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt
+ install -Dm644 shfmt.1.gz "$pkgdir"/usr/share/man/man1/shfmt.1.gz
}
sha512sums="2f019fea811a1a8e995b8fb2ae77ea4f52c0ff82f3b049f22730b5aba8f7a580cf046cb93bc779999805edbc6b9b7c1ab81cdc800bc3068be5631dd947849770 shfmt-3.2.0.tar.gz"