aboutsummaryrefslogtreecommitdiffstats
path: root/community/shiboken2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shiboken2/APKBUILD')
-rw-r--r--community/shiboken2/APKBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/community/shiboken2/APKBUILD b/community/shiboken2/APKBUILD
deleted file mode 100644
index 1a63c2153ea..00000000000
--- a/community/shiboken2/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=shiboken2
-pkgver=5.15.2
-pkgrel=2
-pkgdesc="CPython bindings generator for C++ libraries"
-url="https://wiki.qt.io/Qt_for_Python/Shiboken"
-arch="all !armhf !mips !mips64" # qt5-qtxmlpatterns -> qt5-qtdeclarative
-license="GPL-2.0-or-later"
-depends_dev="python3-dev"
-makedepends="
- cmake
- $depends_dev
- qt5-qtbase-dev
- qt5-qtxmlpatterns-dev
- clang-dev
- libxml2-dev
- libxslt-dev
- py3-numpy-dev
- "
-subpackages="lib$pkgname:libs lib$pkgname-dev py3-$pkgname:py3"
-source="
- https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/pyside-setup-opensource-src-$pkgver.tar.xz
- "
-builddir="$srcdir/pyside-setup-opensource-src-$pkgver"
-
-provides="shiboken=$pkgver-r$pkgrel" # For backward compatibility
-replaces="shiboken" # For backward compatibility
-
-build() {
-
- export CLANG_INSTALL_DIR=/usr
- cmake -B "$builddir"/build sources/shiboken2 \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
- -DBUILD_TESTS=OFF \
- -DUSE_PYTHON_VERSION=3
- make -C build
-}
-
-package() {
- make -C build DESTDIR="$pkgdir" install
-}
-
-libs() {
- license="LGPL-2.1-or-later"
- default_libs
-}
-
-dev() {
- license="LGPL-2.1-or-later"
- default_dev
- provides="shiboken-dev=$pkgver-r$pkgrel"
- replaces="shiboken-dev"
-}
-
-py3() {
- license="LGPL-2.1-or-later"
- depends=""
- pkgdesc="Python3 shiboken bindings"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib
- provides="py3-shiboken=$pkgver-r$pkgrel" # For backward compatibility
- replaces="py3-shiboken" # For backward compatibility
-}
-
-sha512sums="5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62 pyside-setup-opensource-src-5.15.2.tar.xz"