aboutsummaryrefslogtreecommitdiffstats
path: root/community/shiboken6/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shiboken6/APKBUILD')
-rw-r--r--community/shiboken6/APKBUILD75
1 files changed, 0 insertions, 75 deletions
diff --git a/community/shiboken6/APKBUILD b/community/shiboken6/APKBUILD
deleted file mode 100644
index c63b791cec4..00000000000
--- a/community/shiboken6/APKBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Luca Weiss <luca@z3ntu.xyz>
-pkgname=shiboken6
-pkgver=6.3.0
-pkgrel=0
-pkgdesc="CPython bindings generator for C++ libraries"
-url="https://doc.qt.io/qtforpython/shiboken6/"
-arch="all"
-license="GPL-2.0-or-later"
-depends_dev="python3-dev"
-makedepends="
- $depends_dev
- clang-dev
- clang-static
- cmake
- libxml2-dev
- libxslt-dev
- llvm-dev
- llvm-static
- py3-numpy-dev
- py3-setuptools
- qt6-qtbase-dev
- samurai
- "
-subpackages="lib$pkgname:libs lib$pkgname-dev py3-$pkgname:py3"
-source="
- https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/pyside-setup-opensource-src-$pkgver.tar.xz
- fix-6.3.0-build.patch
- "
-builddir="$srcdir/pyside-setup-opensource-src-$pkgver"
-
-build() {
- export CLANG_INSTALL_DIR=/usr
- cmake -B build -G Ninja sources/shiboken6 \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DBUILD_TESTS=OFF \
- -DUSE_PYTHON_VERSION=3 \
- -DCMAKE_SKIP_RPATH=ON
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-libs() {
- license="LGPL-2.1-or-later"
- default_libs
-}
-
-dev() {
- license="LGPL-2.1-or-later"
- default_dev
-}
-
-py3() {
- license="LGPL-2.1-or-later"
- depends=""
- pkgdesc="Python3 shiboken bindings"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib
-
- # Install egg info
- cd "$builddir"
- export PATH="/usr/lib/qt6/bin:$PATH"
- python3 setup.py egg_info --build-type=shiboken6
- pythonpath="$(python3 -c "from sysconfig import get_path; print(get_path('platlib'))")"
- cp -r shiboken6.egg-info "$subpkgdir/$pythonpath"
-}
-
-sha512sums="
-81894465199300a2b7a2afddb6b26295a46ef619ae1f55f1ebac751c0f7f65c092217f612130d1efccc7ffca1f765d1a574656a33e15e75521eca99256d913f3 pyside-setup-opensource-src-6.3.0.tar.xz
-79eca26275f1de2b796a1bd2b0177f58e7e972e13a76e19b0066397f60718acd033df0b7336f29e0f0957fb7ff1208b525b7d91a7621387361ce89b91ea945bc fix-6.3.0-build.patch
-"