aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotcut/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shotcut/APKBUILD')
-rw-r--r--community/shotcut/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/shotcut/APKBUILD b/community/shotcut/APKBUILD
new file mode 100644
index 00000000000..10f07e20f55
--- /dev/null
+++ b/community/shotcut/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=shotcut
+pkgver=24.02.29
+pkgrel=0
+pkgdesc="Cross-platform video editor"
+url="https://www.shotcut.org"
+# armhf, armv7: no opengl1.1 support, only 2
+# aarch64: upstream does not support gcc
+# riscv64: no opencv
+arch="all !armhf !armv7 !aarch64 !riscv64"
+license="GPL-3.0-or-later"
+depends="ffmpeg"
+makedepends="
+ cmake
+ fftw-dev
+ mlt-dev
+ qt6-qtcharts-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
+ qt6-qttools-dev
+ qt6-qtwebsockets-dev
+ samurai
+ "
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.xz::https://github.com/mltframework/shotcut/releases/download/v$pkgver/shotcut-src-${pkgver//./}.txz
+ launcher
+ "
+builddir="$srcdir/src/shotcut"
+options="!check" # No test suite present
+
+build() {
+ export CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG -DSHOTCUT_NOUPGRADE"
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+lang() {
+ pkgdesc="Languages for package shotcut"
+ install_if="$pkgname=$pkgver-r$pkgrel lang"
+ amove usr/share/shotcut/translations
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+ mv "$pkgdir"/usr/bin/shotcut "$pkgdir"/usr/bin/shotcut-real
+ install -Dm755 "$srcdir"/launcher "$pkgdir"/usr/bin/shotcut
+}
+
+sha512sums="
+6d9f24a2eaa4162b9d6502c06e2f889eb0961fd95b34846e7f88d538027fc694f6c9b7b5c4c889528dfe3dfece68728db42e7933ca8a56149bde9e5c9039d749 shotcut-24.02.29.tar.xz
+c9d4263cf5c4a1964ad73fb810353e338e6417e3241a177f444ef151c2da7970eaaa0ca94cfcf52da4d3fe9b1abc4d5fac78361c287aa7e10e3aab2026893cca launcher
+"