aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shotwell/APKBUILD')
-rw-r--r--community/shotwell/APKBUILD49
1 files changed, 35 insertions, 14 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index 48c3bb291f4..fb052135beb 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -1,33 +1,54 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shotwell
-pkgver=0.30.11
-pkgrel=1
-pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
+pkgver=0.32.6
+pkgrel=0
+pkgdesc="Digital photo organizer designed for the GNOME desktop environment"
url="https://wiki.gnome.org/Apps/Shotwell"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all"
license="CC-BY-SA-3.0 AND LGPL-2.1-or-later"
subpackages="$pkgname-lang $pkgname-doc"
-makedepends="vala libgee-dev webkit2gtk-dev libexif-dev
- sqlite-dev libgudev-dev dbus-glib-dev libgphoto2-dev gexiv2-dev libraw-dev
- librsvg-dev json-glib-dev gst-plugins-base-dev gtk+3.0-dev rest-dev
- gcr-dev itstool libgdata-dev meson"
-checkdepends="desktop-file-utils appstream-glib"
+makedepends="
+ dbus-glib-dev
+ desktop-file-utils
+ gcr-dev
+ gexiv2-dev
+ gst-plugins-base-dev
+ gtk+3.0-dev
+ itstool
+ json-glib-dev
+ libexif-dev
+ libgdata-dev
+ libgee-dev
+ libgphoto2-dev
+ libgudev-dev
+ libportal-dev
+ libraw-dev
+ libsecret-dev
+ meson
+ sqlite-dev
+ vala
+ webkit2gtk-4.1-dev
+ "
+checkdepends="appstream-glib"
source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
build() {
abuild-meson \
- -Dinstall-apport-hook=false \
+ -Db_lto=true \
+ -Dinstall_apport_hook=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="71a057aa1ae2b432f385e174429e29f46ca29055aa6003b6017f3da54551027536c70e9f8ca605719e8e008233bdb6f17981462a54495d91e94aebdbe5718c9f shotwell-0.30.11.tar.xz"
+sha512sums="
+7cc536d4ab6b1e746cf0007d041fde51d5ab69f3a26bda6cab5bcc65744b993bf441114280c69496291849e14100451ad732879a0cb35c29e968a12ad442c400 shotwell-0.32.6.tar.xz
+"