aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell
diff options
context:
space:
mode:
Diffstat (limited to 'community/shotwell')
-rw-r--r--community/shotwell/APKBUILD49
-rw-r--r--community/shotwell/shotwell.post-install7
-rw-r--r--community/shotwell/shotwell.post-upgrade7
-rw-r--r--community/shotwell/shotwell.pre-deinstall7
4 files changed, 70 insertions, 0 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
new file mode 100644
index 00000000000..a0b865fe32d
--- /dev/null
+++ b/community/shotwell/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=shotwell
+pkgver=0.22.0
+pkgrel=1
+pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
+url="http://yorba.org/shotwell/"
+arch="all"
+license="LGPL2.1"
+install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
+depends=""
+subpackages="$pkgname-lang"
+makedepends="intltool vala libgee-dev libunique3-dev webkitgtk-dev libexif-dev
+ librsvg-dev sqlite-dev eudev-dev dbus-glib-dev libgphoto2-dev
+ gexiv2-dev libraw-dev librsvg-dev json-glib-dev gnome-doc-utils
+ m4 gst-plugins-base1-dev bash gtk+3.0-dev rest-dev desktop-file-utils"
+install=
+source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ patch -Np0 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build () {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure \
+ --build=$CBUILD \
+ --prefix=/usr \
+ --disable-desktop-update \
+ --disable-icon-update \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="18421a67a1b859caf8542777a42b9ce3 shotwell-0.22.0.tar.xz"
+sha256sums="01b192c5c1c188ecd11bfdb6143d8f177f313c7eab7fe320bd20ac3ca352f831 shotwell-0.22.0.tar.xz"
+sha512sums="486f27a1fa06512a925ecae60504f3cbc487d44834f635efd0897dd20cb304a731c08133ab4b04b32a754235fc8c63dc9b05787b1a0c72a98c89ca91c64f452c shotwell-0.22.0.tar.xz"
diff --git a/community/shotwell/shotwell.post-install b/community/shotwell/shotwell.post-install
new file mode 100644
index 00000000000..e6135da0452
--- /dev/null
+++ b/community/shotwell/shotwell.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/shotwell/shotwell.post-upgrade b/community/shotwell/shotwell.post-upgrade
new file mode 100644
index 00000000000..e6135da0452
--- /dev/null
+++ b/community/shotwell/shotwell.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/shotwell/shotwell.pre-deinstall b/community/shotwell/shotwell.pre-deinstall
new file mode 100644
index 00000000000..9d3a0003005
--- /dev/null
+++ b/community/shotwell/shotwell.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in shotwell.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done