aboutsummaryrefslogtreecommitdiffstats
path: root/community/skanlite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/skanlite/APKBUILD')
-rw-r--r--community/skanlite/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/skanlite/APKBUILD b/community/skanlite/APKBUILD
index 76f37c36071..50d28f00e1e 100644
--- a/community/skanlite/APKBUILD
+++ b/community/skanlite/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=skanlite
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/graphics/skanlite"
pkgdesc="Lite image scanning application"
license="LicenseRef-KDE-Accepted-GPL"
@@ -17,15 +19,17 @@ makedepends="
kio-dev
kxmlgui-dev
libksane-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/skanlite-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/skanlite.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/skanlite-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -33,8 +37,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +45,5 @@ package() {
}
sha512sums="
-b988c3dba6e7a40aab906839bea275bc5decc76271029dc8a4351423e9d983899e151d0432d8109b518a0c5946fd8744291b4eeeaf385152eb816b387a95d53f skanlite-22.04.0.tar.xz
+53e395d8f7199840393b6c5e427fa8989eebd9a6c9474e88c0e2c1428e7c858acf19ee32d6865f154ecba259f8a0b03da5e38f75122f36ea47efcbc92fd8bceb skanlite-24.02.2.tar.xz
"