aboutsummaryrefslogtreecommitdiffstats
path: root/community/skopeo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/skopeo/APKBUILD')
-rw-r--r--community/skopeo/APKBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index e60de883ea4..381262b85f4 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -1,32 +1,49 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=skopeo
-pkgver=1.4.1
-pkgrel=1
+pkgver=1.14.2
+pkgrel=2
+# set this to the gitrev of the version
+_gitrev=b673eb60b754ddd8ba9eeea1dc2e8d8ad03037ac
pkgdesc="Work with remote images registries - retrieving information, images, signing content"
url="https://github.com/containers/skopeo"
license="Apache-2.0"
arch="all"
-options="chmod-clean !check" # needs docker
+options="net !check" # needs docker
depends="containers-common"
makedepends="
- go
- go-md2man
- linux-headers
+ bash
btrfs-progs-dev
glib-dev
+ go
+ go-md2man
gpgme-dev
+ libselinux-dev
+ linux-headers
lvm2-dev
ostree-dev
- libselinux-dev
"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/containers/skopeo/archive/v$pkgver/skopeo-$pkgver.tar.gz"
-export GOPATH="$srcdir"
+# secfixes:
+# 1.5.2-r0:
+# - CVE-2021-41190
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -o bin/$pkgname ./cmd/$pkgname
+ # https://github.com/mattn/go-sqlite3/issues/1164
+ export CGO_CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+
+ make GIT_COMMIT=$_gitrev all
}
check() {
@@ -34,9 +51,10 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" PREFIX=/usr install-binary install-docs install-completions
+ make DESTDIR="$pkgdir" PREFIX=/usr install-docs install-completions
+ install -Dm755 bin/skopeo -t "$pkgdir"/usr/bin/
}
sha512sums="
-71185f772293696a068ccbdf79b9452248a66123a6df3b6f9e4c475d8787ef2c72d3b95bd6efa23044dfcc884f92a7cb704328a6a258439f331fd7e5ac607c30 skopeo-1.4.1.tar.gz
+ffb3c00cdde05f7a916bd3980c9cec1bb82b3f3bf90058bfff1837d3a9902087ac011828e6164baec18210d4aeee1a5258b75405411fd15ea2470a2522a6da73 skopeo-1.14.2.tar.gz
"