aboutsummaryrefslogtreecommitdiffstats
path: root/community/skopeo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/skopeo/APKBUILD')
-rw-r--r--community/skopeo/APKBUILD63
1 files changed, 35 insertions, 28 deletions
diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index e3ec1f13ab2..381262b85f4 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -1,35 +1,49 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=skopeo
-pkgver=0.1.40
-pkgrel=0
+pkgver=1.14.2
+pkgrel=2
+# set this to the gitrev of the version
+_gitrev=b673eb60b754ddd8ba9eeea1dc2e8d8ad03037ac
pkgdesc="Work with remote images registries - retrieving information, images, signing content"
url="https://github.com/containers/skopeo"
-arch="all"
license="Apache-2.0"
-options="!check" # needs docker
+arch="all"
+options="net !check" # needs docker
+depends="containers-common"
makedepends="
- go
- linux-headers
+ bash
btrfs-progs-dev
glib-dev
+ go
+ go-md2man
gpgme-dev
+ libselinux-dev
+ linux-headers
lvm2-dev
ostree-dev
- libselinux-dev
"
-source="skopeo-$pkgver.tar.gz::https://github.com/containers/skopeo/archive/v$pkgver.tar.gz"
-builddir="$srcdir/src/github.com/containers/$pkgname"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
+source="https://github.com/containers/skopeo/archive/v$pkgver/skopeo-$pkgver.tar.gz"
-prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- default_prepare
-}
+# secfixes:
+# 1.5.2-r0:
+# - CVE-2021-41190
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- export GOPATH="$srcdir"
- go build -o bin/$pkgname ./cmd/$pkgname
+ # https://github.com/mattn/go-sqlite3/issues/1164
+ export CGO_CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+
+ make GIT_COMMIT=$_gitrev all
}
check() {
@@ -37,17 +51,10 @@ check() {
}
package() {
- mkdir -p "$pkgdir"/var/lib/atomic/sigstore
- install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 "$builddir"/default-policy.json \
- "$pkgdir"/etc/containers/policy.json
- install -Dm644 "$builddir"/default.yaml \
- "$pkgdir"/etc/containers/registries.d/default.yaml
-}
-
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
+ make DESTDIR="$pkgdir" PREFIX=/usr install-docs install-completions
+ install -Dm755 bin/skopeo -t "$pkgdir"/usr/bin/
}
-sha512sums="161edb8afa961e48e314cf70a4fcebd971a45a50fc11eab6ec751ba4eb05a8be011d16b83c4ed1fa9d6336846da5f518da006d4476ee4e29a160c629820773d3 skopeo-0.1.40.tar.gz"
+sha512sums="
+ffb3c00cdde05f7a916bd3980c9cec1bb82b3f3bf90058bfff1837d3a9902087ac011828e6164baec18210d4aeee1a5258b75405411fd15ea2470a2522a6da73 skopeo-1.14.2.tar.gz
+"