aboutsummaryrefslogtreecommitdiffstats
path: root/community/skopeo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/skopeo/APKBUILD')
-rw-r--r--community/skopeo/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index 7f21b9c20f9..381262b85f4 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -1,32 +1,49 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=skopeo
-pkgver=1.2.3
-pkgrel=0
+pkgver=1.14.2
+pkgrel=2
+# set this to the gitrev of the version
+_gitrev=b673eb60b754ddd8ba9eeea1dc2e8d8ad03037ac
pkgdesc="Work with remote images registries - retrieving information, images, signing content"
url="https://github.com/containers/skopeo"
license="Apache-2.0"
arch="all"
-options="chmod-clean !check" # needs docker
+options="net !check" # needs docker
+depends="containers-common"
makedepends="
- go
- go-md2man
- linux-headers
+ bash
btrfs-progs-dev
glib-dev
+ go
+ go-md2man
gpgme-dev
+ libselinux-dev
+ linux-headers
lvm2-dev
ostree-dev
- libselinux-dev
- containers-common
"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/containers/skopeo/archive/v$pkgver/skopeo-$pkgver.tar.gz"
-export GOPATH="$srcdir"
+# secfixes:
+# 1.5.2-r0:
+# - CVE-2021-41190
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -o bin/$pkgname ./cmd/$pkgname
+ # https://github.com/mattn/go-sqlite3/issues/1164
+ export CGO_CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+
+ make GIT_COMMIT=$_gitrev all
}
check() {
@@ -34,7 +51,10 @@ check() {
}
package() {
- make PREFIX=/usr DESTDIR="$pkgdir" install-binary install-docs install-completions
+ make DESTDIR="$pkgdir" PREFIX=/usr install-docs install-completions
+ install -Dm755 bin/skopeo -t "$pkgdir"/usr/bin/
}
-sha512sums="06e3ddc17f45a7b145c44c58d67894d3fff809cd1521753027c703c44425241d4580096fd44d9156eae70336544110e2af95ab6f9d22deff88903c6e77bbe4d8 skopeo-1.2.3.tar.gz"
+sha512sums="
+ffb3c00cdde05f7a916bd3980c9cec1bb82b3f3bf90058bfff1837d3a9902087ac011828e6164baec18210d4aeee1a5258b75405411fd15ea2470a2522a6da73 skopeo-1.14.2.tar.gz
+"