aboutsummaryrefslogtreecommitdiffstats
path: root/community/skopeo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/skopeo/APKBUILD')
-rw-r--r--community/skopeo/APKBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index 8d34f491d09..381262b85f4 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -1,38 +1,48 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=skopeo
-pkgver=1.8.0
-pkgrel=1
+pkgver=1.14.2
+pkgrel=2
# set this to the gitrev of the version
-_gitrev=49084d2cd8c9f8e7b38ba8405d61e701d5381bc0
+_gitrev=b673eb60b754ddd8ba9eeea1dc2e8d8ad03037ac
pkgdesc="Work with remote images registries - retrieving information, images, signing content"
url="https://github.com/containers/skopeo"
license="Apache-2.0"
arch="all"
-options="chmod-clean !check" # needs docker
+options="net !check" # needs docker
depends="containers-common"
makedepends="
bash
- go
- go-md2man
- linux-headers
btrfs-progs-dev
glib-dev
+ go
+ go-md2man
gpgme-dev
+ libselinux-dev
+ linux-headers
lvm2-dev
ostree-dev
- libselinux-dev
"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/containers/skopeo/archive/v$pkgver/skopeo-$pkgver.tar.gz"
# secfixes:
# 1.5.2-r0:
# - CVE-2021-41190
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
+ # https://github.com/mattn/go-sqlite3/issues/1164
+ export CGO_CFLAGS="$CFLAGS -D_LARGEFILE64_SOURCE"
+
make GIT_COMMIT=$_gitrev all
}
@@ -42,9 +52,9 @@ check() {
package() {
make DESTDIR="$pkgdir" PREFIX=/usr install-docs install-completions
- install -D -m755 -t "$pkgdir"/usr/bin bin/skopeo
+ install -Dm755 bin/skopeo -t "$pkgdir"/usr/bin/
}
sha512sums="
-697242244e533b597f481005754301efed8581018cdc297e071fa24347301ddf6111d1f1d3ccc6e87e3e5a9ea606e9c6b40c47bf69d2df6b44336fb260f546de skopeo-1.8.0.tar.gz
+ffb3c00cdde05f7a916bd3980c9cec1bb82b3f3bf90058bfff1837d3a9902087ac011828e6164baec18210d4aeee1a5258b75405411fd15ea2470a2522a6da73 skopeo-1.14.2.tar.gz
"