aboutsummaryrefslogtreecommitdiffstats
path: root/community/sloci-image/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sloci-image/APKBUILD')
-rw-r--r--community/sloci-image/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/sloci-image/APKBUILD b/community/sloci-image/APKBUILD
new file mode 100644
index 00000000000..745b6ba0d08
--- /dev/null
+++ b/community/sloci-image/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=sloci-image
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple script for creating single-layer OCI images"
+url="https://github.com/jirutka/sloci-image"
+arch="noarch"
+license="MIT"
+depends="/bin/sh tar"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ ./sloci-image --version
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="ef97a253c8fc8ddf141b5b5985c34fcf890ab881a6c658f7f6200c59ab3a4641e60e0cbe6adc6bafc3cbd348643f5ac7f2308cf650d5468a4e4c998a36597a56 sloci-image-0.1.0.tar.gz"