aboutsummaryrefslogtreecommitdiffstats
path: root/community/sn0int/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sn0int/APKBUILD')
-rw-r--r--community/sn0int/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/sn0int/APKBUILD b/community/sn0int/APKBUILD
index f8c2d7ba9cc..6235ac8d06a 100644
--- a/community/sn0int/APKBUILD
+++ b/community/sn0int/APKBUILD
@@ -1,33 +1,35 @@
# Contributor: kpcyrd <git@rxv.cc>
# Maintainer: kpcyrd <git@rxv.cc>
pkgname=sn0int
-pkgver=0.22.0
+pkgver=0.26.0
pkgrel=0
pkgdesc="Semi-automatic OSINT framework and package manager"
url="https://github.com/kpcyrd/sn0int"
-# mips64, s390x and riscv64 blocked by cargo
+# s390x and riscv64 blocked by cargo
# ppc64le blocked by ring crate
-arch="all !mips64 !s390x !ppc64le !riscv64"
+arch="all !s390x !ppc64le !riscv64"
license="GPL-3.0-or-later"
makedepends="
cargo
- lua5.2-dev
- sqlite-dev
+ cargo-auditable
+ libcap-utils
libseccomp-dev
libsodium-dev
+ lua5.2-dev
py3-sphinx
- libcap
+ sqlite-dev
"
subpackages="$pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
-options="net"
source="$pkgname-$pkgver.tar.gz::https://github.com/kpcyrd/sn0int/archive/v$pkgver.tar.gz"
+# setcap: used for chroot to hardcoded location + drops all privs
+options="setcap net"
build() {
- cargo build --release --locked
+ cargo auditable build --release --locked
mkdir -p completions
"target/release/sn0int" completions bash > completions/sn0int.bash
@@ -54,9 +56,9 @@ package() {
install -Dm644 "$builddir/completions/_sn0int" \
"$pkgdir/usr/share/zsh/site-functions/_sn0int"
install -Dm644 "$builddir/completions/sn0int.fish" \
- "$pkgdir/usr/share/fish/completions/sn0int.fish"
+ "$pkgdir/usr/share/fish/vendor_completions.d/sn0int.fish"
}
sha512sums="
-3c4c932baab58435c463506baca0c054915f7407f0374101c7224a2c28680cc65b0aae7f164e81e7b2dc8f8493f44418ee0614917821d23e592bcb334abe3b93 sn0int-0.22.0.tar.gz
+4e416a494947e3bf9170452155189022cfbee15340c1a471672c711931ab7ea2ae6e7f3dcf060542d69ef18d2842342baa5ff413491045fb6258f2c0c577e4f6 sn0int-0.26.0.tar.gz
"