aboutsummaryrefslogtreecommitdiffstats
path: root/community/snapcast/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/snapcast/APKBUILD')
-rw-r--r--community/snapcast/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/community/snapcast/APKBUILD b/community/snapcast/APKBUILD
index a8d0657938d..04174d91e4e 100644
--- a/community/snapcast/APKBUILD
+++ b/community/snapcast/APKBUILD
@@ -19,7 +19,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/badaix/snapcast/archive/v$pk
$pkgname-server.initd
$pkgname-server.confd
"
-options="!check" # No testsuite
build() {
cmake -B build \
@@ -29,16 +28,15 @@ build() {
-DBUILD_WITH_VORBIS=ON \
-DBUILD_WITH_OPUS=ON \
-DBUILD_WITH_AVAHI=ON
- make -C build
+ cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ bin/snapcast_test
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --install build
}
client() {