aboutsummaryrefslogtreecommitdiffstats
path: root/community/sngrep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sngrep/APKBUILD')
-rw-r--r--community/sngrep/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/sngrep/APKBUILD b/community/sngrep/APKBUILD
index ff4fc69491d..cea608c3139 100644
--- a/community/sngrep/APKBUILD
+++ b/community/sngrep/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=sngrep
-pkgver=1.4.8
+pkgver=1.8.1
pkgrel=0
pkgdesc="display SIP call message flows from a terminal"
url="https://github.com/irontec/sngrep"
@@ -9,10 +9,11 @@ arch="all !ppc64le"
license="GPL-3.0-or-later"
depends="sed"
makedepends="autoconf automake ncurses-dev libpcap-dev
- pcre-dev libgcrypt-dev openssl-dev"
+ pcre2-dev libgcrypt-dev openssl-dev>3"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/irontec/sngrep/archive/v$pkgver.tar.gz
- disabled-not-working-tests.patch"
+ disable-failing-test.patch
+ "
prepare() {
default_prepare
@@ -24,9 +25,10 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--with-openssl \
- --with-pcre \
+ --with-pcre2 \
--disable-logo \
--enable-unicode \
+ --enable-eep \
--enable-ipv6
make
}
@@ -39,5 +41,7 @@ package() {
make DESTDIR="$pkgdir/" install
}
-sha512sums="11082b93ab4e31710639663566729fbe6ee87f512bd767889dc43858489d5937bce00f16c6f4541ddaaaebcd29e37c85f1273ce08ce6bddeb33e17bac42a42d3 sngrep-1.4.8.tar.gz
-89ba9d63fedb28bdb7e066f833811cb3155e5f1a73d2aa09595588326783543229a54f54b387df3161b9df37020fae46743d937855647bc974875a9c188dc989 disabled-not-working-tests.patch"
+sha512sums="
+8c5d176e2e5a6690f6d55a9bde811155c3c12f581df9dc59c3f2701a0c2c845e578d037f1a12e20eeab96a324c8825ad4aaa015b26c6f0febb2c7a0e5e43aee5 sngrep-1.8.1.tar.gz
+7fc1e65fb0fbb81118b7484fefc6501bfc0c87314f3d6dc7c974dc41b8fae38ba0f48d66d4234e3f9d81a63facc42ea8c15fb0f6120f86dc3b4c9b09d1b9539a disable-failing-test.patch
+"