aboutsummaryrefslogtreecommitdiffstats
path: root/community/sngrep
diff options
context:
space:
mode:
Diffstat (limited to 'community/sngrep')
-rw-r--r--community/sngrep/APKBUILD13
-rw-r--r--community/sngrep/disable-failing-test.patch5
2 files changed, 10 insertions, 8 deletions
diff --git a/community/sngrep/APKBUILD b/community/sngrep/APKBUILD
index b11586ae671..cea608c3139 100644
--- a/community/sngrep/APKBUILD
+++ b/community/sngrep/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=sngrep
-pkgver=1.4.10
+pkgver=1.8.1
pkgrel=0
pkgdesc="display SIP call message flows from a terminal"
url="https://github.com/irontec/sngrep"
@@ -9,10 +9,11 @@ arch="all !ppc64le"
license="GPL-3.0-or-later"
depends="sed"
makedepends="autoconf automake ncurses-dev libpcap-dev
- pcre-dev libgcrypt-dev openssl1.1-compat-dev"
+ pcre2-dev libgcrypt-dev openssl-dev>3"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/irontec/sngrep/archive/v$pkgver.tar.gz
- disable-failing-test.patch"
+ disable-failing-test.patch
+ "
prepare() {
default_prepare
@@ -24,7 +25,7 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--with-openssl \
- --with-pcre \
+ --with-pcre2 \
--disable-logo \
--enable-unicode \
--enable-eep \
@@ -41,6 +42,6 @@ package() {
}
sha512sums="
-d3aabe22a31ec5860ec80f94b6556d345d72574e552c4e92dfebdddeaaa5f69caf811fc2fa201ca7af24cabfcbdd530a4f50248ebf0381cef26390a78824d1af sngrep-1.4.10.tar.gz
-89ba9d63fedb28bdb7e066f833811cb3155e5f1a73d2aa09595588326783543229a54f54b387df3161b9df37020fae46743d937855647bc974875a9c188dc989 disable-failing-test.patch
+8c5d176e2e5a6690f6d55a9bde811155c3c12f581df9dc59c3f2701a0c2c845e578d037f1a12e20eeab96a324c8825ad4aaa015b26c6f0febb2c7a0e5e43aee5 sngrep-1.8.1.tar.gz
+7fc1e65fb0fbb81118b7484fefc6501bfc0c87314f3d6dc7c974dc41b8fae38ba0f48d66d4234e3f9d81a63facc42ea8c15fb0f6120f86dc3b4c9b09d1b9539a disable-failing-test.patch
"
diff --git a/community/sngrep/disable-failing-test.patch b/community/sngrep/disable-failing-test.patch
index 571dd6460b5..a4ea5636bb3 100644
--- a/community/sngrep/disable-failing-test.patch
+++ b/community/sngrep/disable-failing-test.patch
@@ -1,13 +1,14 @@
diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 84065bd..dcabb11 100644
+index d5f6a0b..7465539 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
-@@ -1,11 +1,10 @@
+@@ -1,12 +1,11 @@
AUTOMAKE_OPTIONS=subdir-objects
-check_PROGRAMS=test-001 test-002 test-003 test-004 test-005
+check_PROGRAMS=test-001 test-002 test-004 test-005
check_PROGRAMS+=test-006 test-007 test-008 test-009 test-010
+ check_PROGRAMS+=test-011
test_001_SOURCES=test_001.c
test_002_SOURCES=test_002.c