aboutsummaryrefslogtreecommitdiffstats
path: root/community/solid/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/solid/APKBUILD')
-rw-r--r--community/solid/APKBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/community/solid/APKBUILD b/community/solid/APKBUILD
index 1137ce00cb4..4d9ec9bcd4d 100644
--- a/community/solid/APKBUILD
+++ b/community/solid/APKBUILD
@@ -1,31 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=solid
-pkgver=5.84.0
+pkgver=6.1.1
pkgrel=0
pkgdesc="Hardware integration and detection"
-# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtdeclarative-dev"
+depends_dev="qt6-qtdeclarative-dev"
makedepends="$depends_dev
- extra-cmake-modules
bison
doxygen
eudev-dev
+ extra-cmake-modules
flex-dev
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
udisks2-dev
upower-dev
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/solid-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/solid.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/solid-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -33,13 +37,14 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # solidmttest is broken
+ ctest --test-dir build --output-on-failure -E "solidmttest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-2c646c1347312cb3cc716cd35b90da8057d09546c3e90cb0dab823c6cc07495efa04fe980503ed201e5cbcb763e130a8f0444b46139dbdf2e6749a445821616e solid-5.84.0.tar.xz
+d30e6426e418791f0cab72fb5ab54ed2d8ff98212959fee5a4e661db2165a0b920f3a1c36ebc518b4659b36640429e31925200946a45999d874424f4756158d5 solid-6.1.1.tar.xz
"