aboutsummaryrefslogtreecommitdiffstats
path: root/community/sonnet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sonnet/APKBUILD')
-rw-r--r--community/sonnet/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/sonnet/APKBUILD b/community/sonnet/APKBUILD
index 06d7758cafd..3810a8b9ea1 100644
--- a/community/sonnet/APKBUILD
+++ b/community/sonnet/APKBUILD
@@ -1,22 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=sonnet
-pkgver=5.84.0
+pkgver=6.0.0
pkgrel=0
-pkgdesc="Spelling framework for Qt5"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+pkgdesc="Spelling framework for Qt"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends="hunspell"
-depends_dev="qt5-qtbase"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen hunspell-dev"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ hunspell-dev
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/sonnet-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/sonnet.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/sonnet-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -24,15 +38,14 @@ build() {
}
check() {
- cd build
-
# sonnet-test_autodetect fails to detect a speller backend
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "sonnet-test_autodetect"
+ xvfb-run ctest --test-dir build --output-on-failure -E "sonnet-test_autodetect"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-49021de3684d899b20b2ba8f980a701e3f467b0a9f76935fc38c347881a371bb0c51f924d44fc819f86119589df1391427365aabd92c1eebbd66f8d46bdf901d sonnet-5.84.0.tar.xz
+3482c7b7d72023c32aebeb22dcd11a274fe9c9efcbdbedcf7ee03fbf0c209d92c8b9f72cf513f172c7260c08043812c6cbbafcb9e002b69ae9fca5d5d026cbaa sonnet-6.0.0.tar.xz
"