aboutsummaryrefslogtreecommitdiffstats
path: root/community/soundtouch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/soundtouch/APKBUILD')
-rw-r--r--community/soundtouch/APKBUILD43
1 files changed, 20 insertions, 23 deletions
diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
index 90f80a14722..4b40c63488a 100644
--- a/community/soundtouch/APKBUILD
+++ b/community/soundtouch/APKBUILD
@@ -1,14 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=soundtouch
-pkgver=2.2
+pkgver=2.3.3
pkgrel=0
pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
url="http://www.surina.net/soundtouch/"
arch="all"
license="LGPL-2.0-or-later"
-makedepends="autoconf automake libtool"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://gitlab.com/soundtouch/soundtouch/-/archive/$pkgver/soundtouch-$pkgver.tar.bz2"
+makedepends="cmake samurai"
+subpackages="$pkgname-dev"
+source="https://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
+ no-fast.patch
+ "
+builddir="$srcdir/$pkgname"
+options="!check" # no tests
# secfixes:
# 2.1.2-r0:
@@ -16,28 +20,21 @@ source="https://gitlab.com/soundtouch/soundtouch/-/archive/$pkgver/soundtouch-$p
# - CVE-2018-17097
# - CVE-2018-17098
-prepare() {
- default_prepare
- ./bootstrap
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-shared \
- --disable-static
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DOPENMP=ON \
+ -DNEON=OFF
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/doc
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="8bc1b9aa60031145e8be7ab48d10d93da84b0f5032eb2d8cf46291d4267b6810513f284f6fa72dd6f343e30eeec03070a7485cd933f30bace2ebf995bc843143 soundtouch-2.2.tar.bz2"
+sha512sums="
+9cc507e15be065fe404e3f9ac71cdc596474c4a86b04a4b969c6c3ed4aff865cdf6aee24929046818a7d3791f005778aea112d74ef4d8f60b05460755a08dbe3 soundtouch-2.3.3.tar.gz
+a2aa7ce31d2625a61b4b13aa5ddc3da68b949a8a41fb655b0324f188cc72b75080f85ffeed93ceab3d6b3f652c4df0e99ea1ef12bc7aec57528a2299a689fd7e no-fast.patch
+"