aboutsummaryrefslogtreecommitdiffstats
path: root/community/sparsehash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sparsehash/APKBUILD')
-rw-r--r--community/sparsehash/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/sparsehash/APKBUILD b/community/sparsehash/APKBUILD
new file mode 100644
index 00000000000..6b4886a7d9f
--- /dev/null
+++ b/community/sparsehash/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sparsehash
+pkgver=2.0.3
+pkgrel=0
+pkgdesc="Library that contains several hash-map implementations"
+url="https://github.com/sparsehash/sparsehash"
+arch="all"
+license="BSD-3-Clause"
+subpackages="$pkgname-doc"
+source="https://github.com/sparsehash/sparsehash/archive/sparsehash-$pkgver.tar.gz"
+builddir="$srcdir"/sparsehash-sparsehash-$pkgver
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bb00d0acb8eba65f7da8015ea4f6bebf8bba36ed6777881960ee215f22b7be17b069c59838d210551ce67a34baccfc7b2fed603677ec53c0c32714d8e76f5d6c sparsehash-2.0.3.tar.gz"