aboutsummaryrefslogtreecommitdiffstats
path: root/community/spectacle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/spectacle/APKBUILD')
-rw-r--r--community/spectacle/APKBUILD61
1 files changed, 50 insertions, 11 deletions
diff --git a/community/spectacle/APKBUILD b/community/spectacle/APKBUILD
index 8fc6af07791..84c92e36ba9 100644
--- a/community/spectacle/APKBUILD
+++ b/community/spectacle/APKBUILD
@@ -1,30 +1,69 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=spectacle
-pkgver=20.04.1
+pkgver=24.02.1
pkgrel=0
pkgdesc="Application for capturing desktop screenshots"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x and riscv64 blocked by qt6-qtwebengine -> purpose
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.spectacle"
license="GPL-2.0-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev kconfig-dev ki18n-dev kio-dev kwindowsystem-dev kdoctools-dev knewstuff-dev kdeclarative-dev libkipi-dev purpose-dev kwayland-dev xcb-util-image-dev xcb-util-cursor-dev libxcb-dev xcb-util-renderutil-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/spectacle-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ kconfig-dev
+ kcoreaddons-dev
+ kdbusaddons-dev
+ kdeclarative-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ knewstuff-dev
+ knotifications-dev
+ kpipewire-dev
+ kwayland-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ layer-shell-qt-dev
+ libxcb-dev
+ pipewire-dev
+ purpose-dev
+ qt6-qtbase-dev
+ samurai
+ xcb-util-cursor-dev
+ xcb-util-image-dev
+ xcb-util-renderutil-dev
+ "
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/spectacle.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/spectacle-$pkgver.tar.xz
+ spectacle.desktop
+ "
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "filename_test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
+
+ install -Dm644 "$srcdir"/spectacle.desktop -t "$pkgdir"/etc/xdg/autostart/
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/usr/lib/systemd
}
-sha512sums="72e3dbb4aed66beffc0f969d5f4a3f09584be0326a37e4da7caf2272cf2bb6a7b09237edf80c42462e476cacb9a34014a1a68e02d430638eee80974720975a00 spectacle-20.04.1.tar.xz"
+sha512sums="
+3f4e91b96196eaea9dc7bb1347081784581339786da7e074c5be6199331a214d0bf4ec6023779b9cd9e274a4cb442d9edc597913e503318176b21f463dedc38a spectacle-24.02.1.tar.xz
+7c563d811f30d26f83e01a465e803b95167c5b2b842315257216ab282e07c69e7582a14d7f429cd19678199179ad8f3f2854265092f5a4c9ce9b65c87ed3849d spectacle.desktop
+"