aboutsummaryrefslogtreecommitdiffstats
path: root/community/spectacle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/spectacle/APKBUILD')
-rw-r--r--community/spectacle/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/spectacle/APKBUILD b/community/spectacle/APKBUILD
index d25c9376548..1900f392413 100644
--- a/community/spectacle/APKBUILD
+++ b/community/spectacle/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=spectacle
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="Application for capturing desktop screenshots"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kdeclarative
-# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+# ppc64le, s390x and riscv64 blocked by qt6-qtwebengine -> purpose
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.spectacle"
license="GPL-2.0-only"
makedepends="
@@ -21,34 +23,36 @@ makedepends="
kio-dev
knewstuff-dev
knotifications-dev
+ kpipewire-dev
kwayland-dev
kwidgetsaddons-dev
kwindowsystem-dev
- libkipi-dev
+ layer-shell-qt-dev
libxcb-dev
+ pipewire-dev
purpose-dev
- qt5-qtbase-dev
- qt5-qtx11extras-dev
+ qt6-qtbase-dev
+ samurai
xcb-util-cursor-dev
xcb-util-image-dev
xcb-util-renderutil-dev
"
+subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/spectacle.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/spectacle-$pkgver.tar.xz
spectacle.desktop
"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "filename_test"
}
package() {
@@ -60,6 +64,6 @@ package() {
rm -r "$pkgdir"/usr/lib/systemd
}
sha512sums="
-86af85d322c8d1231c4c47edaf886077dcfd1b20a33d6022ef5a8a543261e3d9f8c7b33957140d32f346c3dbaa87e13c9bed25b391771185468b4994e7ca3841 spectacle-21.04.3.tar.xz
+52269013adadce38d7faa6ddd8d4be8935bbfca70c3d906b24d78d19b55595b7d0cfffaa008c42030c08ccf82ea46742a4d81c9d0cf01fcc31073a2bede93d88 spectacle-24.02.2.tar.xz
7c563d811f30d26f83e01a465e803b95167c5b2b842315257216ab282e07c69e7582a14d7f429cd19678199179ad8f3f2854265092f5a4c9ce9b65c87ed3849d spectacle.desktop
"