aboutsummaryrefslogtreecommitdiffstats
path: root/community/station/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/station/APKBUILD')
-rw-r--r--community/station/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/station/APKBUILD b/community/station/APKBUILD
new file mode 100644
index 00000000000..a52c3527708
--- /dev/null
+++ b/community/station/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
+pkgname=station
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Convergent terminal emulator"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://invent.kde.org/maui/station"
+license="GPL-3.0-or-later"
+depends="
+ qmltermwidget
+ mauikit-terminal
+ "
+makedepends="
+ extra-cmake-modules
+ kcoreaddons5-dev
+ ki18n5-dev
+ mauikit-dev
+ mauikit-filebrowsing-dev
+ mauikit-terminal-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ samurai
+ "
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/station.git"
+source="https://download.kde.org/stable/maui/station/$pkgver/station-$pkgver.tar.xz"
+options="!check" # No tests
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+d26c2d31f453c9af78ef4c83606821cdb402a86534e2e1b0e8f7867173a11bac1a88887ca91ca31dc488e7e39e2c18aadb3addb9851dafe26edea303f0e0a723 station-3.0.2.tar.xz
+"