aboutsummaryrefslogtreecommitdiffstats
path: root/community/stellarium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stellarium/APKBUILD')
-rw-r--r--community/stellarium/APKBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/community/stellarium/APKBUILD b/community/stellarium/APKBUILD
index 9f0f32325c0..70fd2e65ed5 100644
--- a/community/stellarium/APKBUILD
+++ b/community/stellarium/APKBUILD
@@ -1,33 +1,46 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=stellarium
-pkgver=0.21.1
-pkgrel=1
+pkgver=24.1
+pkgrel=0
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
-url="http://stellarium.org/"
-arch="all !mips !mips64 !armhf" # Limited by qt5-qtmultimedia-dev
+url="https://stellarium.org/"
+# gigantic package
+arch="aarch64 x86_64"
license="GPL-2.0-or-later"
makedepends="
- cmake boost-dev mesa-dev qt5-qttools-dev libpng-dev freetype-dev
- openssl-dev qt5-qtscript-dev qt5-qtserialport-dev qt5-qtmultimedia-dev
- qt5-qtlocation-dev gpsd-dev
-"
+ boost-dev
+ cmake
+ freetype-dev
+ gpsd-dev
+ libpng-dev
+ mesa-dev
+ openssl-dev>3
+ qt5-qtcharts-dev
+ qt5-qtlocation-dev
+ qt5-qtmultimedia-dev
+ qt5-qtscript-dev
+ qt5-qtserialport-dev
+ qt5-qttools-dev
+ samurai
+ "
subpackages="$pkgname-doc"
-source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.gz"
-[ "$CARCH" = "x86" ] && options="!check"
+source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.xz"
build() {
- cmake -B build \
+ # SHOWMYSKY support needs qt5-qtopengl
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_TESTING=1
+ -DENABLE_TESTING=1 \
+ -DENABLE_SHOWMYSKY=OFF
cmake --build build
}
check() {
- cd build
# Exclude a broken locale test
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI|StelSkyCultureMgr)'
+ ctest --test-dir build --output-on-failure \
+ -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI)'
}
package() {
@@ -35,5 +48,5 @@ package() {
}
sha512sums="
-6dd935808c711da32c793a0cedad464a15bf35ede60cff385e96f1d5868e751ed2e09b61551f7a6fe599b702a6f4d0a62d4494a40b68e77685ba57b6a63b5031 stellarium-0.21.1.tar.gz
+60e0e2afb214f4e2d9ba6640f4b699d18c97b05b9f33e9990787a87484c6bd1d7bc87685558956e6dc8a80e93abd8d7f677daeb55d38d8f4f8448e7936999246 stellarium-24.1.tar.xz
"