aboutsummaryrefslogtreecommitdiffstats
path: root/community/stellarium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stellarium/APKBUILD')
-rw-r--r--community/stellarium/APKBUILD50
1 files changed, 31 insertions, 19 deletions
diff --git a/community/stellarium/APKBUILD b/community/stellarium/APKBUILD
index 0a8c647e703..d8de47f30e3 100644
--- a/community/stellarium/APKBUILD
+++ b/community/stellarium/APKBUILD
@@ -1,40 +1,52 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=stellarium
-pkgver=0.21.1
-pkgrel=0
+pkgver=24.1
+pkgrel=1
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
-url="http://stellarium.org/"
-arch="all !mips !mips64 !armhf" # Limited by qt5-qtmultimedia-dev
+url="https://stellarium.org/"
+# gigantic package
+arch="aarch64 x86_64"
license="GPL-2.0-or-later"
makedepends="
- cmake boost-dev mesa-dev qt5-qttools-dev libpng-dev freetype-dev
- openssl-dev qt5-qtscript-dev qt5-qtserialport-dev qt5-qtmultimedia-dev
- qt5-qtlocation-dev gpsd-dev
-"
+ boost-dev
+ cmake
+ freetype-dev
+ gpsd-dev
+ libpng-dev
+ mesa-dev
+ openssl-dev>3
+ qt5-qtcharts-dev
+ qt5-qtlocation-dev
+ qt5-qtmultimedia-dev
+ qt5-qtscript-dev
+ qt5-qtserialport-dev
+ qt5-qttools-dev
+ samurai
+ "
subpackages="$pkgname-doc"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/Stellarium/stellarium/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
-"
+source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.xz"
build() {
- cmake \
+ # SHOWMYSKY support needs qt5-qtopengl
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_TESTING=1 \
- .
- make
+ -DENABLE_SHOWMYSKY=OFF
+ cmake --build build
}
check() {
- [ "$CARCH" = "x86" ] && return 0
# Exclude a broken locale test
- ctest -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI|StelSkyCultureMgr)'
+ ctest --test-dir build --output-on-failure \
+ -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI)'
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-6dd935808c711da32c793a0cedad464a15bf35ede60cff385e96f1d5868e751ed2e09b61551f7a6fe599b702a6f4d0a62d4494a40b68e77685ba57b6a63b5031 stellarium-0.21.1.tar.gz
+60e0e2afb214f4e2d9ba6640f4b699d18c97b05b9f33e9990787a87484c6bd1d7bc87685558956e6dc8a80e93abd8d7f677daeb55d38d8f4f8448e7936999246 stellarium-24.1.tar.xz
"