aboutsummaryrefslogtreecommitdiffstats
path: root/community/stellarium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stellarium/APKBUILD')
-rw-r--r--community/stellarium/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/stellarium/APKBUILD b/community/stellarium/APKBUILD
index 7990a3f44bb..70fd2e65ed5 100644
--- a/community/stellarium/APKBUILD
+++ b/community/stellarium/APKBUILD
@@ -1,11 +1,12 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=stellarium
-pkgver=0.22.1
-pkgrel=1
+pkgver=24.1
+pkgrel=0
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
-url="http://stellarium.org/"
-arch="all !armhf" # Limited by qt5-qtmultimedia-dev
+url="https://stellarium.org/"
+# gigantic package
+arch="aarch64 x86_64"
license="GPL-2.0-or-later"
makedepends="
boost-dev
@@ -14,30 +15,32 @@ makedepends="
gpsd-dev
libpng-dev
mesa-dev
- openssl1.1-compat-dev
+ openssl-dev>3
qt5-qtcharts-dev
qt5-qtlocation-dev
qt5-qtmultimedia-dev
qt5-qtscript-dev
qt5-qtserialport-dev
qt5-qttools-dev
-"
+ samurai
+ "
subpackages="$pkgname-doc"
-source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.gz"
-[ "$CARCH" = "x86" ] && options="!check"
+source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.xz"
build() {
- cmake -B build \
+ # SHOWMYSKY support needs qt5-qtopengl
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_TESTING=1
+ -DENABLE_TESTING=1 \
+ -DENABLE_SHOWMYSKY=OFF
cmake --build build
}
check() {
- cd build
# Exclude a broken locale test
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI|StelSkyCultureMgr)'
+ ctest --test-dir build --output-on-failure \
+ -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI)'
}
package() {
@@ -45,5 +48,5 @@ package() {
}
sha512sums="
-31d0294c78c3254261dd2a5e46022342f9f3046f920efd8e4f1353eecf79116f50a968479768c12a8419ed3f9182fd3694a78b5ea2ab27ad67e6ef6d17aaa137 stellarium-0.22.1.tar.gz
+60e0e2afb214f4e2d9ba6640f4b699d18c97b05b9f33e9990787a87484c6bd1d7bc87685558956e6dc8a80e93abd8d7f677daeb55d38d8f4f8448e7936999246 stellarium-24.1.tar.xz
"