aboutsummaryrefslogtreecommitdiffstats
path: root/community/stellarium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stellarium/APKBUILD')
-rw-r--r--community/stellarium/APKBUILD52
1 files changed, 33 insertions, 19 deletions
diff --git a/community/stellarium/APKBUILD b/community/stellarium/APKBUILD
index b360cec2fdd..70fd2e65ed5 100644
--- a/community/stellarium/APKBUILD
+++ b/community/stellarium/APKBUILD
@@ -1,38 +1,52 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=stellarium
-pkgver=0.20.2
-pkgrel=1
+pkgver=24.1
+pkgrel=0
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
-url="http://stellarium.org/"
-arch="all !mips !mips64 !armhf" # Limited by qt5-qtmultimedia-dev
+url="https://stellarium.org/"
+# gigantic package
+arch="aarch64 x86_64"
license="GPL-2.0-or-later"
makedepends="
- cmake boost-dev mesa-dev qt5-qttools-dev libpng-dev freetype-dev
- openssl-dev qt5-qtscript-dev qt5-qtserialport-dev qt5-qtmultimedia-dev
- qt5-qtlocation-dev gpsd-dev
-"
+ boost-dev
+ cmake
+ freetype-dev
+ gpsd-dev
+ libpng-dev
+ mesa-dev
+ openssl-dev>3
+ qt5-qtcharts-dev
+ qt5-qtlocation-dev
+ qt5-qtmultimedia-dev
+ qt5-qtscript-dev
+ qt5-qtserialport-dev
+ qt5-qttools-dev
+ samurai
+ "
subpackages="$pkgname-doc"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/Stellarium/stellarium/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
-"
+source="https://github.com/Stellarium/stellarium/releases/download/v$pkgver/stellarium-$pkgver.tar.xz"
build() {
- cmake \
+ # SHOWMYSKY support needs qt5-qtopengl
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_TESTING=1 \
- .
- make
+ -DENABLE_SHOWMYSKY=OFF
+ cmake --build build
}
check() {
- [ "$CARCH" = "x86" ] && return 0
# Exclude a broken locale test
- ctest -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI|StelSkyCultureMgr)'
+ ctest --test-dir build --output-on-failure \
+ -E 'test(INDIConnection|TelescopeControl_INDI|TelescopeClientINDI)'
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="34f1ad5891dde84b53324046bdf1514df858335ba8f0954bb72350b057ff6dc4091a2d7bf89083489e0d8d1c750c5fb8ba8e1e241f9287a740121b377f0e510c stellarium-0.20.2.tar.gz"
+sha512sums="
+60e0e2afb214f4e2d9ba6640f4b699d18c97b05b9f33e9990787a87484c6bd1d7bc87685558956e6dc8a80e93abd8d7f677daeb55d38d8f4f8448e7936999246 stellarium-24.1.tar.xz
+"