aboutsummaryrefslogtreecommitdiffstats
path: root/community/step/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/step/APKBUILD')
-rw-r--r--community/step/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/step/APKBUILD b/community/step/APKBUILD
index 39bd1b6514b..18cfe939962 100644
--- a/community/step/APKBUILD
+++ b/community/step/APKBUILD
@@ -1,10 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=step
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by khtml
+# s390x blocked by
# riscv64 disabled due to missing rust in recursive dependency
arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/step/"
@@ -16,21 +19,22 @@ makedepends="
kconfig-dev
kcrash-dev
kdoctools-dev
- khtml-dev
kiconthemes-dev
knewstuff-dev
kplotting-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
- qt5-qttools-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ qt6-qttools-dev
samurai
shared-mime-info
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/step-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/education/step.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/step-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -38,14 +42,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-1e4882588ad16e1087b352f40bd6945ade32d843c695092a0c95d0aaeaeb66e77e551733e1a9175c4f3bd08ce6aada22cee24c6d504334183476fae9fb3166be step-22.04.1.tar.xz
+35d6df48c97dc13f3247673706a37ad64c3bbc25dfc65a8e3364363563f6df31f60e66ab97ee6c3f78017ff93e66e77781cd421bf43a8f26823e6631781212b1 step-24.02.2.tar.xz
"