aboutsummaryrefslogtreecommitdiffstats
path: root/community/stig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stig/APKBUILD')
-rw-r--r--community/stig/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/stig/APKBUILD b/community/stig/APKBUILD
new file mode 100644
index 00000000000..e5a1e9feb42
--- /dev/null
+++ b/community/stig/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Anjandev Momi <anjan@momi.ca>
+# Maintainer: Anjandev Momi <anjan@momi.ca>
+pkgname=stig
+pkgver=0.12.5_alpha0
+pkgrel=1
+pkgdesc="TUI and CLI client for the BitTorrent client Transmission"
+url="https://github.com/rndusr/stig"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3 py3-urwid py3-urwidtrees py3-aiohttp py3-async-timeout py3-xdg py3-blinker py3-natsort py3-setproctitle"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rndusr/stig/archive/refs/tags/v${pkgver//_alpha/a}.tar.gz"
+options="!check" # py3-asynctest library is not compatible with Python 3.8 and above. See https://github.com/rndusr/stig/issues/206
+builddir=$srcdir/stig-${pkgver//_alpha/a}
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+f4e0a978664cea8ed5d645c1fe3cb01c07105262b1531b9ee89c3d0f2351c284479881eb3e89f7b940f319bcc28965dae1ea5cc64875d245b9810042b82be397 stig-0.12.5_alpha0.tar.gz
+"