aboutsummaryrefslogtreecommitdiffstats
path: root/community/stow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stow/APKBUILD')
-rw-r--r--community/stow/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/stow/APKBUILD b/community/stow/APKBUILD
index 2e17b49f910..0c4b28f4391 100644
--- a/community/stow/APKBUILD
+++ b/community/stow/APKBUILD
@@ -1,24 +1,24 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
-# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=stow
-pkgver=2.3.1
-pkgrel=0
+pkgver=2.4.0
+pkgrel=1
pkgdesc="Manage installation of multiple softwares in the same directory tree"
url="https://www.gnu.org/software/stow/"
arch="noarch"
license="GPL-3.0-or-later"
depends="perl"
-makedepends="perl-test-output"
-checkdepends="perl-io-stringy"
+checkdepends="perl-test-output"
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/pub/gnu/stow/stow-$pkgver.tar.bz2"
+source="https://ftp.gnu.org/gnu/stow/stow-$pkgver.tar.bz2"
build() {
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --with-pmdir=/usr/lib/perl5/vendor_perl
+ --with-pmdir=/usr/share/perl5/vendor_perl
+ make
}
check() {
@@ -31,4 +31,6 @@ package() {
rm "$pkgdir"/usr/share/doc/stow/version.texi
}
-sha512sums="3d6cec3d50e2dc0ffa92646c45015ced3fca32cef9dd24418fada3fc2e4472a1f335877debb3a1284812aef281a432925c3a3e7afa112d92f127facd3150079c stow-2.3.1.tar.bz2"
+sha512sums="
+c479a0ba5d6af9a2a4860f4bf4095dbd586794e781766c22e6cda657bbf984915f4661e03825db02a300412aa49305e06b8107ffc96077bd64ba4e7a1eb27314 stow-2.4.0.tar.bz2
+"