aboutsummaryrefslogtreecommitdiffstats
path: root/community/stress-ng/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stress-ng/APKBUILD')
-rw-r--r--community/stress-ng/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/community/stress-ng/APKBUILD b/community/stress-ng/APKBUILD
index 1182ed37254..0ab3aa6687c 100644
--- a/community/stress-ng/APKBUILD
+++ b/community/stress-ng/APKBUILD
@@ -1,24 +1,26 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=stress-ng
-pkgver=0.12.06
+pkgver=0.17.07
pkgrel=0
pkgdesc="stress-ng will stress test a computer system in various selectable ways"
-url="https://kernel.ubuntu.com/~cking/stress-ng/"
-arch="all !mips !mips64"
+url="https://github.com/ColinIanKing/stress-ng"
+arch="all"
license="GPL-2.0-or-later"
options="!check" # tests are not portable
makedepends="
+ judy-dev
libaio-dev
libbsd-dev
linux-headers
lksctp-tools-dev
zlib-dev
"
-subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
-source="https://kernel.ubuntu.com/~cking/tarballs/stress-ng/stress-ng-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-bash-completion"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ColinIanKing/stress-ng/archive/refs/tags/V$pkgver.tar.gz"
build() {
+ export CFLAGS="${CFLAGS/-Os/-O2}"
make
}
@@ -27,12 +29,6 @@ package() {
JOBDIR="/usr/share/doc/$pkgname/example-jobs/" install
}
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- amove usr/share/bash-completion/completions
-}
-
-sha512sums="bdfbee6c1d339dc4d288aa28b08bdaf158f49bb023b527c653e7956d80607690fe4aab763acc8c6659e822f2e225ee2be39ff60effa972b05c4c5e0fe067d6fc stress-ng-0.12.06.tar.xz"
+sha512sums="
+5bd6dc8175d2d410447559c489e7bb1187fdce7657018ac48a2744be6e8998bc21e84b7bc536477b5db170ca9bd2aba0992127af90e3ff2312bd6130061dce6c stress-ng-0.17.07.tar.gz
+"