aboutsummaryrefslogtreecommitdiffstats
path: root/community/stunnel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stunnel/APKBUILD')
-rw-r--r--community/stunnel/APKBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/community/stunnel/APKBUILD b/community/stunnel/APKBUILD
index 8b8bbb92cce..ac217cccce2 100644
--- a/community/stunnel/APKBUILD
+++ b/community/stunnel/APKBUILD
@@ -3,20 +3,34 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=stunnel
-pkgver=5.60
+pkgver=5.72
pkgrel=0
pkgdesc="SSL encryption wrapper between network client and server"
url="https://www.stunnel.org"
arch="all"
-license="GPL-2.0-or-later with OpenSSL exception"
+license="GPL-2.0-or-later WITH OpenSSL-Exception"
# support for SO_ORIGINAL_DST will be silently disabled without linux-headers
-makedepends="openssl-dev linux-headers"
+makedepends="openssl-dev>3 linux-headers"
+checkdepends="py3-cryptography"
subpackages="$pkgname-doc $pkgname-openrc"
install="$pkgname.pre-install"
-source="https://www.stunnel.org/downloads/stunnel-$pkgver.tar.gz
+source="https://www.stunnel.org/archive/${pkgver%%.*}.x/stunnel-$pkgver.tar.gz
stunnel.initd
stunnel.conf"
+prepare() {
+ default_prepare
+
+ # remove FIPS-related tests
+ rm tests/plugins/p10_fips.py
+ rm tests/plugins/p11_fips_cipher.py
+
+ # Hangs forever on s390x.
+ if [ "$CARCH" = s390x ]; then
+ rm tests/plugins/p02_require_cert.py
+ fi
+}
+
build() {
./configure \
--build=$CBUILD \
@@ -30,6 +44,7 @@ build() {
}
check() {
+ timeout 300 \
make check
}
@@ -45,7 +60,7 @@ package() {
}
sha512sums="
-4ad0423a7e52c0db8746caf4b64ff69abe1f5c880417779d9933597d7ca86f240b64b578dc3e625fba04bbbddad7aa056dd62d2ecdf6d6a842ffa228bace705e stunnel-5.60.tar.gz
+2607bed1159412dc36ed0455ed158ab3141782f05ddaf3605076f1a0e371bc1ada1606cab65a6bc52d69a8c685345617578cb79d521330f2e1d12af3dcbd37ca stunnel-5.72.tar.gz
51d56a6c0d961f6de5cd2ef07a1cfdb19fb1b74300da9c340899daa919bd9b2c0bfff472f03746df0dd1aa6098c79035921ca36108ca0b93693377f1ac1c7fb4 stunnel.initd
a72bfddeb74787d58c9fd24782d86c0498ce3530a43fbdd4ec4c4b57baa6257b6ef21005aca274b22c4a22cdbbbcee63dd3d841f458af248db9c69e8d59fa56f stunnel.conf
"