aboutsummaryrefslogtreecommitdiffstats
path: root/community/stunnel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/stunnel/APKBUILD')
-rw-r--r--community/stunnel/APKBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/community/stunnel/APKBUILD b/community/stunnel/APKBUILD
index 29886005ac8..ac217cccce2 100644
--- a/community/stunnel/APKBUILD
+++ b/community/stunnel/APKBUILD
@@ -3,20 +3,34 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=stunnel
-pkgver=5.55
+pkgver=5.72
pkgrel=0
pkgdesc="SSL encryption wrapper between network client and server"
url="https://www.stunnel.org"
arch="all"
-license="GPL-2.0-or-later with OpenSSL exception"
+license="GPL-2.0-or-later WITH OpenSSL-Exception"
# support for SO_ORIGINAL_DST will be silently disabled without linux-headers
-makedepends="openssl-dev linux-headers"
+makedepends="openssl-dev>3 linux-headers"
+checkdepends="py3-cryptography"
subpackages="$pkgname-doc $pkgname-openrc"
install="$pkgname.pre-install"
-source="https://www.stunnel.org/downloads/archive/${pkgver%.*}.x/stunnel-$pkgver.tar.gz
+source="https://www.stunnel.org/archive/${pkgver%%.*}.x/stunnel-$pkgver.tar.gz
stunnel.initd
stunnel.conf"
+prepare() {
+ default_prepare
+
+ # remove FIPS-related tests
+ rm tests/plugins/p10_fips.py
+ rm tests/plugins/p11_fips_cipher.py
+
+ # Hangs forever on s390x.
+ if [ "$CARCH" = s390x ]; then
+ rm tests/plugins/p02_require_cert.py
+ fi
+}
+
build() {
./configure \
--build=$CBUILD \
@@ -30,10 +44,7 @@ build() {
}
check() {
- # FIXME: those fails for unknown reason
- rm tests/recipes/037_failover_prio1
- rm tests/recipes/038_failover_prio2
-
+ timeout 300 \
make check
}
@@ -48,6 +59,8 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/examples/
}
-sha512sums="278e39e87e080171d2bed3b193f8f7923b48c12c6d788afeb113a71bfc6077129305e8f93f5e7046b12cc8aa381e89909358756c978ef129d3067ceeb60e112a stunnel-5.55.tar.gz
-33e215413e08fdd5783cc76e6ba6a2342fb6d0573f801815c4d3022625e71be6c9739d47a7a61bf7c803f27911b9c92cf6ae3e522add040f83802e1aaeaee000 stunnel.initd
-a72bfddeb74787d58c9fd24782d86c0498ce3530a43fbdd4ec4c4b57baa6257b6ef21005aca274b22c4a22cdbbbcee63dd3d841f458af248db9c69e8d59fa56f stunnel.conf"
+sha512sums="
+2607bed1159412dc36ed0455ed158ab3141782f05ddaf3605076f1a0e371bc1ada1606cab65a6bc52d69a8c685345617578cb79d521330f2e1d12af3dcbd37ca stunnel-5.72.tar.gz
+51d56a6c0d961f6de5cd2ef07a1cfdb19fb1b74300da9c340899daa919bd9b2c0bfff472f03746df0dd1aa6098c79035921ca36108ca0b93693377f1ac1c7fb4 stunnel.initd
+a72bfddeb74787d58c9fd24782d86c0498ce3530a43fbdd4ec4c4b57baa6257b6ef21005aca274b22c4a22cdbbbcee63dd3d841f458af248db9c69e8d59fa56f stunnel.conf
+"