aboutsummaryrefslogtreecommitdiffstats
path: root/community/suitesparse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/suitesparse/APKBUILD')
-rw-r--r--community/suitesparse/APKBUILD77
1 files changed, 46 insertions, 31 deletions
diff --git a/community/suitesparse/APKBUILD b/community/suitesparse/APKBUILD
index c8a40f341ae..d8e3af389fa 100644
--- a/community/suitesparse/APKBUILD
+++ b/community/suitesparse/APKBUILD
@@ -2,49 +2,64 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=suitesparse
_pkgname=SuiteSparse
-pkgver=5.3.0
+pkgver=7.3.1
pkgrel=0
pkgdesc="A collection of sparse matrix libraries"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch="all"
-license="GPL"
-depends_dev="openblas-dev>=0.3.0"
-makedepends="$depends_dev cmake"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://faculty.cse.tamu.edu/davis/$_pkgname/$_pkgname-$pkgver.tar.gz
- 0001-exclude-metis.patch
- 0002-remove-rpath.patch
+license="BSD-3-Clause AND LGPL-2.1-or-later AND GPL-2.0-or-later"
+depends_dev="
+ gmp-dev
+ mpfr-dev
+ openblas-dev
"
-builddir="$srcdir/$_pkgname"
-
-prepare() {
- cd "$builddir"
-
- # OpenBLAS provides also LAPACK.
- export LAPACK="-lopenblas"
+makedepends="
+ $depends_dev
+ cmake
+ m4
+ "
+subpackages="
+ $pkgname-static
+ $pkgname-dev
+ $pkgname-graphblas
+ "
+source="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver/$_pkgname-$pkgver.tar.gz
+ remove-rpath.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
- # Do not include the Partition module and METIS (it's optional and
- # Julia doesn't need it).
- export CFLAGS="$CFLAGS -DNPARTITION"
- rm -r metis-*
+_flags="BLAS=-lopenblas LAPACK=-lopenblas"
- default_prepare
-}
+# Do not include the Partition module (it's optional and Julia doesn't need it).
+# Do not try to override optimization level. SuiteSparse is a huge library
+# heavily optimized for performance, so compiling with -Os doesn't make sense.
+# Actually, the build scripts currently override -Os with -O3 anyway,
+# but better to not rely on it.
+export CFLAGS="${CFLAGS/-Os/} -DNPARTITION"
+export CPPFLAGS=${CPPFLAGS/-Os/}
+export CXXFLAGS=${CXXFLAGS/-Os/}
build() {
- cd "$builddir"
- make library
+ make library $_flags CMAKE_OPTIONS="\
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_INCLUDEDIR=/usr/include/suitesparse \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ "
}
package() {
- cd "$builddir"
+ make install $_flags DESTDIR="$pkgdir"
+}
+
+graphblas() {
+ pkgdesc="Graph algorithms in the language of linear algebra"
+ license="Apache-2.0 AND GPL-3.0-or-later"
- make install \
- INSTALL="$pkgdir/usr" \
- INSTALL_INCLUDE="$pkgdir/usr/include/$pkgname" \
- INSTALL_DOC="$pkgdir/usr/share/doc/$pkgname"
+ amove usr/lib/libgraphblas.so.*
}
-sha512sums="a7ac655c5454c8270a52ece802946893f02d12c1bfb10546e24cd8355e59b733961526e9d702cd649b90b47bb325ace5110f70054db3754c732bc3ec1fa42cf9 SuiteSparse-5.3.0.tar.gz
-0bdaed29c7770104eb94d9e60a42fe68b5643c8f958aba4cc6d7996888a83ae75a4e509d0c262264c49d5d9b1ca23a958cc71cfaa5e983b0008e65455a987cac 0001-exclude-metis.patch
-cd40b696515b26c95298b435a5111e582dc42c2fa2e8ef9889558467d375b1d19452838b9463df66958e73ddb0c8c0191936e3e952586a3c7d345edb08fa7e62 0002-remove-rpath.patch"
+sha512sums="
+681d64349360246aaebea3246a87a7415c3528b4cde4aef6def3988e19087d7184ce1bf1fad0f80f7ea312d59f6f207dc2195f6be100871c5714115705c243f6 SuiteSparse-7.3.1.tar.gz
+79886862a6edfcec8462ccb973ced03aa09968166c317964f107f43222b3b6be8e21aadb4c242696f4b2e1c34f2403c4bdd6d006c6aecc3b84128ba13d079a08 remove-rpath.patch
+"