aboutsummaryrefslogtreecommitdiffstats
path: root/community/supercronic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/supercronic/APKBUILD')
-rw-r--r--community/supercronic/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/supercronic/APKBUILD b/community/supercronic/APKBUILD
index c12e465b96f..63612096b0c 100644
--- a/community/supercronic/APKBUILD
+++ b/community/supercronic/APKBUILD
@@ -1,23 +1,23 @@
# Contributor: Thomas Kienlen <kommander@laposte.net>
# Maintainer: Thomas Kienlen <kommander@laposte.net>
pkgname=supercronic
-pkgver=0.1.12
-pkgrel=7
+pkgver=0.2.29
+pkgrel=1
pkgdesc="Cron for containers"
url="https://github.com/aptible/supercronic"
arch="all"
license="MIT"
makedepends="go"
checkdepends="python3"
-source="supercronic-$pkgver.tar.gz::https://github.com/aptible/supercronic/archive/refs/tags/v$pkgver.tar.gz
- python3.patch
- "
+source="supercronic-$pkgver.tar.gz::https://github.com/aptible/supercronic/archive/refs/tags/v$pkgver.tar.gz"
options="chmod-clean"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- go build \
- -trimpath \
- -ldflags "-s -w"
+ go build -trimpath
}
check() {
@@ -29,5 +29,6 @@ package() {
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="d3b9238647e8f10a1f844e1c4311a493492c46b10f51384874d1a7e66f6e7bf30a94d8f5fd89344198d40026bb77494377ac0244b236a31ac350d8eb981e132c supercronic-0.1.12.tar.gz
-fd88eccd0a18d65af57292e430a1c69b2de1d5c845522e1e1b8b217ab11b8d974543da747debbd6cd2c03d0929dcc04c028a0dc95fc27433331a0dec61d1dfae python3.patch"
+sha512sums="
+87c1e0958335585bcfea023dac01bb2f4b515bd3866d9b01941fa7f614c77a211825ba86328212f0a5a02a21b0fa8d36767d4886ad5f7a2d8a691dff9bfe6fad supercronic-0.2.29.tar.gz
+"