aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxmo-dwm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sxmo-dwm/APKBUILD')
-rw-r--r--community/sxmo-dwm/APKBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/community/sxmo-dwm/APKBUILD b/community/sxmo-dwm/APKBUILD
index dd6e42fbd63..0bb4eff54f8 100644
--- a/community/sxmo-dwm/APKBUILD
+++ b/community/sxmo-dwm/APKBUILD
@@ -1,23 +1,33 @@
# Maintainer: Anjandev Momi <anjan@momi.ca>
+# Contributor: Maarten van Gompel <proycon@anaproy.nl>
pkgname=sxmo-dwm
-pkgver=6.2.12
-pkgrel=0
+pkgver=6.3.0
+pkgrel=1
pkgdesc="Dwm fork for Sxmo UI; supports volume-key hotkeys, swallow, keyboard, among other patches"
url="https://git.sr.ht/~mil/sxmo-dwm"
arch="all"
license="MIT"
depends="xorg-server"
-makedepends="libxft-dev libx11-dev libxinerama-dev"
+makedepends="libxft-dev libx11-dev libxinerama-dev pango-dev"
subpackages="$pkgname-doc"
provides="dwm"
+provider_priority=10
options="!check" # has no tests
-source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/sxmo-dwm/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver-2.tar.gz::https://git.sr.ht/~mil/sxmo-dwm/archive/$pkgver.tar.gz"
prepare() {
default_prepare
sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
-e '/LDFLAGS/{s/=/+=/}' \
"$builddir"/config.mk
+
+ case "$CARCH" in
+ x86_64|aarch64) ;;
+ *)
+ sed -i 's|#NOBONSAIFLAGS = -DNOBONSAI|NOBONSAIFLAGS = -DNOBONSAI|' \
+ "$builddir"/config.mk
+ ;;
+ esac
}
build() {
@@ -32,4 +42,6 @@ package() {
-C "$builddir" install
}
-sha512sums="842d93eb51204059e2f10c78dbf61f0239fef176d768b43a4d0b5f39a5ec452546e9fa77bc580a496f57f5a8f90a5576aa59a8964ffb0f86be2e454aec2b27c5 sxmo-dwm-6.2.12.tar.gz"
+sha512sums="
+9a2cfdde48101d56b2f0f91b56b9b51e4cee2e0be195b3d93155950df312ffe3fa79c74a77a3cecf3456ba3b56373230b56aa54b9841791f466af306b181c869 sxmo-dwm-6.3.0-2.tar.gz
+"