aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxmo-dwm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sxmo-dwm/APKBUILD')
-rw-r--r--community/sxmo-dwm/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/sxmo-dwm/APKBUILD b/community/sxmo-dwm/APKBUILD
new file mode 100644
index 00000000000..0bb4eff54f8
--- /dev/null
+++ b/community/sxmo-dwm/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Anjandev Momi <anjan@momi.ca>
+# Contributor: Maarten van Gompel <proycon@anaproy.nl>
+pkgname=sxmo-dwm
+pkgver=6.3.0
+pkgrel=1
+pkgdesc="Dwm fork for Sxmo UI; supports volume-key hotkeys, swallow, keyboard, among other patches"
+url="https://git.sr.ht/~mil/sxmo-dwm"
+arch="all"
+license="MIT"
+depends="xorg-server"
+makedepends="libxft-dev libx11-dev libxinerama-dev pango-dev"
+subpackages="$pkgname-doc"
+provides="dwm"
+provider_priority=10
+options="!check" # has no tests
+source="$pkgname-$pkgver-2.tar.gz::https://git.sr.ht/~mil/sxmo-dwm/archive/$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/=/+=/}' \
+ "$builddir"/config.mk
+
+ case "$CARCH" in
+ x86_64|aarch64) ;;
+ *)
+ sed -i 's|#NOBONSAIFLAGS = -DNOBONSAI|NOBONSAIFLAGS = -DNOBONSAI|' \
+ "$builddir"/config.mk
+ ;;
+ esac
+}
+
+build() {
+ make X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib/X11 \
+ FREETYPEINC=/usr/include/freetype2 \
+ -C "$builddir"
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" \
+ -C "$builddir" install
+}
+
+sha512sums="
+9a2cfdde48101d56b2f0f91b56b9b51e4cee2e0be195b3d93155950df312ffe3fa79c74a77a3cecf3456ba3b56373230b56aa54b9841791f466af306b181c869 sxmo-dwm-6.3.0-2.tar.gz
+"