aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxmo-xdm-config/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sxmo-xdm-config/APKBUILD')
-rw-r--r--community/sxmo-xdm-config/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/sxmo-xdm-config/APKBUILD b/community/sxmo-xdm-config/APKBUILD
new file mode 100644
index 00000000000..83a6dd11070
--- /dev/null
+++ b/community/sxmo-xdm-config/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maarten van Gompel <proycon@anaproy.nl>
+pkgname=sxmo-xdm-config
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="X Display Manager configuration for Sxmo; starts with virtual keyboard and launches Sxmo UI"
+options="!check" # No testsuite
+url="https://git.sr.ht/~mil/sxmo-xdm-config"
+arch="noarch !ppc64le" # blocked by sxmo-utils
+license="MIT"
+depends="sxmo-utils svkbd xdm"
+replaces="sxmo-xdm xdm xdm-openrc"
+subpackages="$pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/sxmo-xdm-config/archive/$pkgver.tar.gz"
+
+package() {
+ mkdir -p "$pkgdir/etc/X11/xdm" "$pkgdir/usr/lib/X11/xdm" "$pkgdir/etc/conf.d" "$pkgdir/etc/profile.d"
+
+ make -C "$builddir" DESTDIR=$pkgdir install
+
+ # E.g. hide the cursor for Xorg
+ echo ":0 local /usr/bin/X -nocursor :0" > "$pkgdir/etc/X11/xdm/Xservers"
+}
+
+sha512sums="d28a1d278727e7885f05b2bed030b5a8e9a3e8b859042380ae8c2d7ac990305d7de81be3a937ccdc9513af2d9caf3f1528680591b0a1e6629fb5591234f5db25 sxmo-xdm-config-0.3.2.tar.gz"