aboutsummaryrefslogtreecommitdiffstats
path: root/community/syndication/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syndication/APKBUILD')
-rw-r--r--community/syndication/APKBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/community/syndication/APKBUILD b/community/syndication/APKBUILD
index b77e758c64c..1d9a6a9ff6c 100644
--- a/community/syndication/APKBUILD
+++ b/community/syndication/APKBUILD
@@ -1,20 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=syndication
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="An RSS/Atom parser library"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND BSD-3-Clause"
-depends_dev="qt5-qtbase-dev kcodecs-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syndication-$pkgver.tar.xz"
+depends_dev="
+ kcodecs-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ doxygen
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/syndication.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syndication-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,13 +35,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-cdab7872f31c6d19d590c9318618f92ac5cab532944320223183fe957030745c1dc170dedbbc0dfcb33d5119974f9c8731090fbda1dce56e78e28a4fa53fbc85 syndication-5.84.0.tar.xz
+40d5e8b40a53ce4e86a48cafc9c1f7a3e92872a366ab381412eb29331126e4e0e89ec76a15c8c4c0be9d2425dd5e1c78f8d9cc36077f169609f245b5b4168e53 syndication-6.1.0.tar.xz
"