aboutsummaryrefslogtreecommitdiffstats
path: root/community/syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syntax-highlighting/APKBUILD')
-rw-r--r--community/syntax-highlighting/APKBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/community/syntax-highlighting/APKBUILD b/community/syntax-highlighting/APKBUILD
index 1872a89fd59..fedb33a6de1 100644
--- a/community/syntax-highlighting/APKBUILD
+++ b/community/syntax-highlighting/APKBUILD
@@ -1,38 +1,48 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=syntax-highlighting
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Syntax highlighting engine for structured text and code"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="MIT"
-depends_dev="qt5-qtbase-dev"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ xerces-c-dev
+ "
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ perl
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/syntax-highlighting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "(test|html)highlighter_test"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-0eef420b8aa3917f28bfd64cbe046ebbfe34e9e537c7641666921d26931b3e5eab671b7b104857930fd35981f55bdce9d114b318b4bad2106479e1c3328b690b syntax-highlighting-5.84.0.tar.xz
+1aebf4507461aca80f5248cbce3311ca5a000b0d5e1f214ca877fd184a9380ac7646fab999901e230717a90047c90a66e8eedb35c224883474e20554b6931690 syntax-highlighting-6.1.0.tar.xz
"