aboutsummaryrefslogtreecommitdiffstats
path: root/community/syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syntax-highlighting/APKBUILD')
-rw-r--r--community/syntax-highlighting/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/syntax-highlighting/APKBUILD b/community/syntax-highlighting/APKBUILD
index 6011c319044..fedb33a6de1 100644
--- a/community/syntax-highlighting/APKBUILD
+++ b/community/syntax-highlighting/APKBUILD
@@ -1,32 +1,48 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=syntax-highlighting
-pkgver=5.70.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Syntax highlighting engine for structured text and code"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="MIT"
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ xerces-c-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ perl
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/syntax-highlighting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "(test|html)highlighter_test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="59a05fd274cb11b893351cc10747600e03ced88cdc738eee26689e9a2a97b07db05805c0b0dcadbf02809254bd170b04f27b8372abb26b769bc6e962c615b9e0 syntax-highlighting-5.70.0.tar.xz"
+
+sha512sums="
+1aebf4507461aca80f5248cbce3311ca5a000b0d5e1f214ca877fd184a9380ac7646fab999901e230717a90047c90a66e8eedb35c224883474e20554b6931690 syntax-highlighting-6.1.0.tar.xz
+"