aboutsummaryrefslogtreecommitdiffstats
path: root/community/syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syntax-highlighting/APKBUILD')
-rw-r--r--community/syntax-highlighting/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/community/syntax-highlighting/APKBUILD b/community/syntax-highlighting/APKBUILD
index 5796504bc6d..fedb33a6de1 100644
--- a/community/syntax-highlighting/APKBUILD
+++ b/community/syntax-highlighting/APKBUILD
@@ -1,21 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=syntax-highlighting
-pkgver=5.94.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Syntax highlighting engine for structured text and code"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="MIT"
-depends_dev="qt5-qtbase-dev"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ xerces-c-dev
+ "
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ perl
+ qt6-qttools-dev
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/syntax-highlighting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -27,8 +36,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "(test|html)highlighter_test"
}
package() {
@@ -36,5 +44,5 @@ package() {
}
sha512sums="
-34e3ec926ae576e0366216c67ee73ef62c538e38369d664ca104951cf08a52848fd7b4d75e29ef23650259b113af727bf71837b6b6ced0f63d4264c0c903acb2 syntax-highlighting-5.94.0.tar.xz
+1aebf4507461aca80f5248cbce3311ca5a000b0d5e1f214ca877fd184a9380ac7646fab999901e230717a90047c90a66e8eedb35c224883474e20554b6931690 syntax-highlighting-6.1.0.tar.xz
"