aboutsummaryrefslogtreecommitdiffstats
path: root/community/targetcli
diff options
context:
space:
mode:
Diffstat (limited to 'community/targetcli')
-rw-r--r--community/targetcli/APKBUILD12
-rwxr-xr-xcommunity/targetcli/targetcli.initd8
2 files changed, 12 insertions, 8 deletions
diff --git a/community/targetcli/APKBUILD b/community/targetcli/APKBUILD
index dc1fd9c5bb5..2fa1544f81d 100644
--- a/community/targetcli/APKBUILD
+++ b/community/targetcli/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=targetcli
-pkgver=2.1.54
-pkgrel=0
+pkgver=2.1.58
+pkgrel=2
pkgdesc="Administration shell for storage targets"
url="https://github.com/open-iscsi/targetcli-fb"
arch="noarch"
license="AGPL-3.0-or-later"
depends="python3 py3-configobj py3-configshell py3-ethtool py3-ipaddr
- py3-parsing py3-rtslib py3-simpleparse py3-six py3-udev py3-dbus dbus
+ py3-parsing py3-rtslib py3-six py3-udev py3-dbus dbus
py3-urwid py3-gobject3"
makedepends="$depends_dev py3-setuptools"
-subpackages="$pkgname-doc $pkgname-openrc"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/open-iscsi/targetcli-fb/archive/v$pkgver.tar.gz
targetcli.initd
targetcli.confd
@@ -41,7 +41,7 @@ package() {
}
sha512sums="
-dd008b8c47acc095078454c94b0c6f19ba88f86ddf1b5335eb050abf61d89ce1ffb7411ff3a174de60ed9759e6337206253aa9b2def6497b85c884a0a111308d targetcli-2.1.54.tar.gz
-ea886be1cf0b2c4266553f3b3f4072c2632ce28d8dd449f355fb2989fac16937a4d022622dad2d965b0b5e4c25e72e5a62fd52ba37b4fe2c334d2e06b4cd2c1b targetcli.initd
+1ef1dda1d8df8e98ba8a5882368477dfb5a0aa880c535dbe526e221dc5be32c49eaadda6c54f60b045288277d6d80dc6b47283fc656144f8ab5cde570d7e6343 targetcli-2.1.58.tar.gz
+e58d00944e9a985ab1ce2ca870920775a1efcfb3324300ff6e5ce8860fd4efc19f91ddbd9155bce070b2be82e914b87105a8848dffa9007dfc7d54b272feb0ab targetcli.initd
b0cedfb351dabcd6febe660dd95b5f2bab89f38849d346e46f57c32a4057f6bd2347e9a93a9e9010f4c7ff91f16c0fd33f02ad0cacf9fb801de76da4d25ad9e3 targetcli.confd
"
diff --git a/community/targetcli/targetcli.initd b/community/targetcli/targetcli.initd
index 589d61d1a8c..6888b202de3 100755
--- a/community/targetcli/targetcli.initd
+++ b/community/targetcli/targetcli.initd
@@ -4,7 +4,7 @@ description="Administration tool for managing RisingTide Systems storage targets
command="/usr/bin/targetcli"
depend() {
- need net
+ need dbus net
after firewall
}
@@ -15,7 +15,11 @@ start() {
done
mount -t configfs none /sys/kernel/config
$command restoreconfig clear_existing=true
- eend $?
+ ret=$?
+ if [ $ret -ne 0 ]; then
+ umount /sys/kernel/config
+ fi
+ eend $ret
}
stop() {