aboutsummaryrefslogtreecommitdiffstats
path: root/community/tclx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/tclx/APKBUILD')
-rw-r--r--community/tclx/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/tclx/APKBUILD b/community/tclx/APKBUILD
index df86d5d6e0f..21cfe60f00c 100644
--- a/community/tclx/APKBUILD
+++ b/community/tclx/APKBUILD
@@ -1,23 +1,21 @@
# Contributor: Shannon Noe <snoe925@gmail.com>
-# Maintainer: Shannon Noe <snoe925@gmail.com>
+# Maintainer: rubicon <rubicon@mailo.com>
pkgname=tclx
-pkgver=8.4.1
-pkgrel=1
+pkgver=8.6.3
+pkgrel=0
pkgdesc="TclX extension to Tcl"
-url="http://tclx.sourceforge.net/"
+url="https://github.com/flightaware/tclx"
arch="all"
license="BSD"
depends="tcl"
depends_dev="tcl-dev"
-makedepends="tcl-dev"
+makedepends="$depends_dev"
+checkdepends="bash"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://downloads.sourceforge.net/project/tclx/TclX/$pkgver/$pkgname$pkgver.tar.bz2
- rresvport.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/flightaware/tclx/archive/v$pkgver.tar.gz
+ process-test.patch
"
-_major=${pkgver%.*}
-builddir="$srcdir"/tclx$_major
-
build() {
local _64bit="--disable-64bit"
case "$CARCH" in
@@ -30,14 +28,20 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --with-tcl=/usr/lib \
+ --enable-threads \
$_64bit
make
}
+check() {
+ make test TESTFLAGS="-verbose pbtels"
+}
+
package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="faad58f5d8e0e1e759da639800f354b583fb01418c94f2274924aa07beb0ee9559beb87b3386ed5ae3694700a71dfe5b8ac54ead0ec75c6963507e9d3ead7060 tclx8.4.1.tar.bz2
-ab0c63de8c9fd6c6fca7a0901c876e013cfc76b5032f7b6dce7cad9d747d7baffd3b4b7ae6d24a34bc1c1c78dbd2bd8169eac27f9d7ed468675963e847f6917c rresvport.patch"
+sha512sums="
+680b8916ccb5725ed173b45549c94e7b1e17c4e5cf700c3991d2791b9f299660e94c880401dccfbff7ca630036c0781c41a9692c2d8ead2e7ad880e2e05a69e7 tclx-8.6.3.tar.gz
+54044611c72f0355bd906f78327605b9f350e265a185478d2e77a32a2b00ef532da8395f7571b470fc9e066ec424b18d295b1b5245e3da64dac0cf57b57f1fd1 process-test.patch
+"