aboutsummaryrefslogtreecommitdiffstats
path: root/community/tea/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/tea/APKBUILD')
-rw-r--r--community/tea/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/community/tea/APKBUILD b/community/tea/APKBUILD
index da0fa777837..1fd8be739b5 100644
--- a/community/tea/APKBUILD
+++ b/community/tea/APKBUILD
@@ -1,32 +1,32 @@
# Contributor: 6543 <6543@obermui.de>
# Maintainer: 6543 <6543@obermui.de>
pkgname=tea
-pkgver=0.8.0
-pkgrel=4
+pkgver=0.9.2
+pkgrel=8
pkgdesc="A command line tool to interact with Gitea servers"
url="https://gitea.com/gitea/tea"
license="MIT"
arch="all"
makedepends="go"
-options="!check" # no testsuite
subpackages="$pkgname-bash-completion"
-source="$pkgname-$pkgver.tar.gz::https://gitea.com/gitea/tea/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver-2.tar.gz::https://gitea.com/gitea/tea/archive/v$pkgver.tar.gz
bash_autocomplete
"
+builddir="$srcdir/$pkgname"
+options="chmod-clean"
-builddir="$srcdir/src/code.gitea.io/$pkgname"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
-prepare() {
- mkdir -p "${builddir%/*}"
- mv $pkgname "$builddir"
- default_prepare
+build() {
+ local sdk=$(go list -f '{{.Version}}' -m code.gitea.io/sdk/gitea)
+
+ go build -ldflags "-X main.Version=$pkgver -X main.SDK=$sdk" -o $pkgname
}
-build() {
- export GOPATH="$srcdir"
- export TEA_VERSION="$pkgver"
- unset LDFLAGS
- make build
+check() {
+ go test ./...
}
package() {
@@ -35,6 +35,6 @@ package() {
}
sha512sums="
-deb67690c92cb2b48612ddf1cf5fb7efed6a6ad516e41956c26981b8abf94854ad6af47daa526242d8632d21b30b07dd681856434b5097c2ce75345ab970da4f tea-0.8.0.tar.gz
+05be2ea5f845773324c10fe8f0340c96f40f392b7ef8cafb44463b7a5492de2216799d8cc339e7dc42e921afcd3ba0e21be133a87385e907af47261733935e62 tea-0.9.2-2.tar.gz
d89c90cde59ec43c0ff3eb9db9928cbb8be765e264eff8dabf2889507a5fe5d4799d89a7b02832c11954d684f232e1265f4aa740c9c5e26954d2ac8f7d4a7a57 bash_autocomplete
"