aboutsummaryrefslogtreecommitdiffstats
path: root/community/telepathy-idle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/telepathy-idle/APKBUILD')
-rw-r--r--community/telepathy-idle/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/telepathy-idle/APKBUILD b/community/telepathy-idle/APKBUILD
index a283ee2933a..8fff1a13f43 100644
--- a/community/telepathy-idle/APKBUILD
+++ b/community/telepathy-idle/APKBUILD
@@ -1,18 +1,25 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=telepathy-idle
-pkgver=0.2.0
-pkgrel=0
-pkgdesc="telepathy-idle is a connection manager for the IRC protocol."
-url="http://telepathy.freedesktop.org"
+pkgver=0.2.2
+pkgrel=2
+pkgdesc="connection manager for the IRC protocol"
+url="https://telepathy.freedesktop.org/"
arch="all"
license="LGPL-2.1-or-later"
makedepends="telepathy-glib-dev glib-dev dbus-dev dbus-glib-dev libxslt
python3"
-options="!check" # Needs py2-dbus
+checkdepends="dbus py3-dbus"
subpackages="$pkgname-doc"
-source="http://telepathy.freedesktop.org/releases/telepathy-idle/telepathy-idle-$pkgver.tar.gz
- python3.patch"
+source="https://telepathy.freedesktop.org/releases/telepathy-idle/telepathy-idle-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+
+ export PATH="$PATH:$PWD"
+ ln -s /usr/bin/python3 python
+}
build() {
./configure \
@@ -33,5 +40,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f5e36afc3ab4b52eb865f2c1e6565b99011a7540fc1a7783d3bbd7bbf50bc671a2147df6bde646c82059a466cc1df9bdb10e2500db5b7bb06d57a989a75c261b telepathy-idle-0.2.0.tar.gz
-c0a22ee03d93e3bc6ab2e4155615771315e38d845ea1a4a60ea095c5cab8872db036e2d74a0aeb0ecbfdaf9f3a22c6a300a241683e69bde51ef5667b0e69aef2 python3.patch"
+sha512sums="c66cf7b70c84a9b7b1ada01712b8d3b683f15a4021bb2d0f6d868b4ab30e2fb12fd26dd8d5ba25b5050e055bf425295049e84a53198d6586f7cfd7c6bc02f826 telepathy-idle-0.2.2.tar.gz"