aboutsummaryrefslogtreecommitdiffstats
path: root/community/template-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/template-glib/APKBUILD')
-rw-r--r--community/template-glib/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/template-glib/APKBUILD b/community/template-glib/APKBUILD
index cd23b466756..365f46dd4c8 100644
--- a/community/template-glib/APKBUILD
+++ b/community/template-glib/APKBUILD
@@ -1,33 +1,38 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=template-glib
-pkgver=3.34.0
+pkgver=3.36.1
pkgrel=1
pkgdesc="library for template expansion which supports calling into GObject Introspection from templates"
url="https://gitlab.gnome.org/GNOME/template-glib"
arch="all"
license="GPL-3.0-or-later"
-makedepends="meson vala gobject-introspection-dev glib-dev flex bison"
+makedepends="
+ bison
+ flex
+ glib-dev
+ gobject-introspection-dev
+ meson
+ vala
+ "
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/template-glib/${pkgver%.*}/template-glib-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=debugoptimized \
+ abuild-meson \
+ -Db_lto=true \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="b89cc9890fd80a6858b34139ce1cd2394a43f598629e59f224f4db798a17457be9a2aa8307828af3591108ed6e9a953936a74df15ed1c8c8af2100306db5a497 template-glib-3.34.0.tar.xz"
+sha512sums="
+7c00d750f7d58e98f2d6c9baa6fa84efde1cce2eaacfb334ef0ee19d0583373d303d67d43cc290cd1a41239f2ee804077e104bb4799b70cfd6760ac3fb04178e template-glib-3.36.1.tar.xz
+"