aboutsummaryrefslogtreecommitdiffstats
path: root/community/tepl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/tepl/APKBUILD')
-rw-r--r--community/tepl/APKBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/community/tepl/APKBUILD b/community/tepl/APKBUILD
index 440b1da993b..912c4855012 100644
--- a/community/tepl/APKBUILD
+++ b/community/tepl/APKBUILD
@@ -1,30 +1,43 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer:
pkgname=tepl
-pkgver=6.00.0
-pkgrel=0
+pkgver=6.4.0
+pkgrel=4
pkgdesc="Text editor product line"
-url="https://wiki.gnome.org/Projects/Tepl"
-arch="all !s390x !mips !mips64" # Limited by gtksourceview4
+url="https://gitlab.gnome.org/swilmet/tepl"
+arch="all"
license="GPL-3.0-or-later"
-makedepends="amtk-dev glib-dev gtksourceview4-dev gtk+3.0-dev libxml2-dev
- uchardet-dev vala gobject-introspection-dev meson gtk-doc"
+depends_dev="
+ amtk-dev
+ glib-dev
+ gtk+3.0-dev
+ "
+makedepends="$depends_dev
+ gobject-introspection-dev
+ gsettings-desktop-schemas-dev
+ gtk-doc
+ gtksourceview4-dev
+ meson
+ vala
+ "
checkdepends="xvfb-run"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/tepl/${pkgver%.*}/tepl-$pkgver.tar.xz"
build() {
abuild-meson \
- -Dgtk_doc=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson compile ${JOBS:+-j ${JOBS}} -C output
+ xvfb-run meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="e36877b9f33943715a50546d82ed61e65fc07b71dca2c85ff350a305767e96eda74dc14f30b2a430e14deacd4ee8d49697fe01df1f5023afab3747e5e9c95e2e tepl-6.00.0.tar.xz"
+
+sha512sums="
+c9c3c720b393ba94d94d58c01f9db72c4713f010551bab31bdfbca6ba416af1c48f1090598f469ce7b41a2ada26fbac4f69632ee411468f3eae84b61b78b60bb tepl-6.4.0.tar.xz
+"