aboutsummaryrefslogtreecommitdiffstats
path: root/community/thonny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/thonny/APKBUILD')
-rw-r--r--community/thonny/APKBUILD47
1 files changed, 38 insertions, 9 deletions
diff --git a/community/thonny/APKBUILD b/community/thonny/APKBUILD
index 4f2969ee93c..56fc7adccd5 100644
--- a/community/thonny/APKBUILD
+++ b/community/thonny/APKBUILD
@@ -1,32 +1,37 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer:
pkgname=thonny
-pkgver=3.3.11
-pkgrel=0
+pkgver=4.1.4
+pkgrel=1
pkgdesc="Python IDE for beginners"
url="https://thonny.org"
-arch="noarch"
+arch="noarch !s390x" # py3-pylint
license="MIT"
depends="
openssl
py3-astroid
py3-asttokens
py3-docutils
+ py3-filelock
+ py3-gpep517
py3-jedi
py3-mypy
py3-pylint
py3-pyperclip
py3-pyserial
py3-send2trash
- py3-toml
+ py3-setuptools
+ py3-wheel
python3-tkinter
"
-makedepends="py3-setuptools"
+subpackages="$pkgname-lang $pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/t/thonny/thonny-$pkgver.tar.gz"
options="!check" # Tests need a DISPLAY
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -34,9 +39,33 @@ check() {
}
package() {
- python3 setup.py install --root="$pkgdir"
+ local pythonpath="$(python3 -c \
+ "from sysconfig import get_path; print(get_path('platlib'))")"
+
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+ rm -r "$pkgdir$pythonpath"/thonny/vendored_libs/filelock
+
+ local appid="org.thonny.Thonny"
+ install -Dm644 packaging/linux/$appid.desktop \
+ -t "$pkgdir"/usr/share/applications
+ install -Dm644 packaging/linux/$appid.appdata.xml \
+ -t "$pkgdir"/usr/share/metainfo
+
+ local size
+ for size in 16 22 32 48 64 128 192 256; do
+ install -Dm644 packaging/icons/thonny-"$size"x"$size".png \
+ "$pkgdir"/usr/share/icons/hicolor/"$size"x"$size"/apps/thonny.png
+ done
+}
+
+lang() {
+ local pythonpath="$(python3 -c \
+ "from sysconfig import get_path; print(get_path('platlib'))")"
+
+ langdir="$pythonpath"/thonny/locale
+ default_lang
}
sha512sums="
-8a2869c20e33c119f9cc0bfc1dd9f95489030ead2d570f25afa18b1380d4d6d400b8927eca17d5dd0df0035d41c004a0f0d71156a5ca4a9e05ec26a3cb9d263c thonny-3.3.11.tar.gz
+89935bf6a0e8e154774bc812a500a3768d5fdd6e4ff9822683db2cc1a92bab751d8b3f19cb23b2db60c44307978e7d5e210ef0b04b33bfecea22eac333d83050 thonny-4.1.4.tar.gz
"