aboutsummaryrefslogtreecommitdiffstats
path: root/community/tilix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/tilix/APKBUILD')
-rw-r--r--community/tilix/APKBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/community/tilix/APKBUILD b/community/tilix/APKBUILD
index 9f97143905a..a77701fed2c 100644
--- a/community/tilix/APKBUILD
+++ b/community/tilix/APKBUILD
@@ -1,32 +1,45 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tilix
-pkgver=1.9.4
+pkgver=1.9.6
pkgrel=0
pkgdesc="Tiling terminal emulator for Linux"
url="https://gnunn1.github.io/tilix-web/"
-arch="x86_64 aarch64" # ldc
+arch="x86_64 aarch64"
license="MPL-2.0"
-depends="gsettings-desktop-schemas libsecret dbus:org.freedesktop.Secrets"
-makedepends="dconf-dev gtkd-dev glib-dev libx11-dev meson ldc ldc-runtime
- ldc-static po4a gdk-pixbuf libsecret-dev appstream desktop-file-utils"
+depends="gsettings-desktop-schemas libsecret dbus:org.freedesktop.Secrets vte3"
+makedepends="
+ appstream
+ dconf-dev
+ desktop-file-utils
+ gdk-pixbuf
+ glib-dev
+ gtkd-dev
+ ldc
+ libsecret-dev
+ libx11-dev
+ meson
+ po4a
+ "
options="!check" # no tests
subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/gnunn1/tilix/archive/$pkgver/tilix-$pkgver.tar.gz
musl-hacks.patch
- dont-use-libunwind.patch"
-
-export LDFLAGS='-linker=bfd -link-defaultlib-shared'
+ dont-use-libunwind.patch
+ "
build() {
+ export LDFLAGS="$LDFLAGS -L--no-export-dynamic"
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="fe73cfca691317af575c37730179732b7b53a0197e9b813c918626094bff7499239c6d48d4a03204896f4f261bdb52d9ceaaf2ba3a2c100b57a0fe05abe5980f tilix-1.9.4.tar.gz
+sha512sums="
+2d51e8c0203863573e52c7bf68a66ba4ec58f929ecebf90bb68bae3f15d9f745f956fc524b7dd23d1804d5130dd0bf39ff834d262042375448e53714021338f6 tilix-1.9.6.tar.gz
3347bfebb0e4d011d9b17f31ed15ec79e503de76185757165c7c13daa6e8b566eb0ad3a7cf32775ee4bc6102da1fa593d3dd0ff57767748c911ec46ad53d4bc3 musl-hacks.patch
-4a1ccc6011d64b78a7f2a93ca91eec36004c5e5d4e826efc115f860c3013bd52477324b586340e18849bce445c56d7d8b909393694ec43a3b11d0c85e6ad59c3 dont-use-libunwind.patch"
+4a1ccc6011d64b78a7f2a93ca91eec36004c5e5d4e826efc115f860c3013bd52477324b586340e18849bce445c56d7d8b909393694ec43a3b11d0c85e6ad59c3 dont-use-libunwind.patch
+"